Purge Caching won't work

Since I get on a regular base spam I tried to purge the cache from my web site. I run the Purge All from Cloudflare direct as well as as from the Wordpress plugin.

https://www.liebenauer-welsch.at/wp-content/plugins/contact-form-7-style/admin/predefined-templates.json

Altough the specific file is not any longer available I get a response and the HEADER says cloudflare. Therefore I’m thinking the content is still cached with Cloudflare.

Any idea how to clear the cache? I would expect to get a HTTP status 404 (or similar).

I see nothing in the header to indicate that Cloudflare would cache that URL:

You can try this command to check the server’s response as well. Be sure to replace the 123.123 part with the actual IP address of your server:

curl https://www.liebenauer-welsch.at/wp-content/plugins/contact-form-7-style/admin/predefined-templates.json --connect-to ::123.123.123.123

If I do so as you recommended I get the following result

which is quite similar to your screenshot. The main reason why I think the URL is cached from Cloudflare:

  • server field mentions ‘cloudflare’
  • report-uri mentions cloudflare as well as ‘cf-cache-status’ would be interpreted as ‘cloudflare-cache-status’

Did you check that your hosting provider has activated any cache mod in the server?
Cloudflare and Wordpress can’t control what happens inside the origin server.

I’ve asked some time ago. The response was quite clear. All the data is forwarded directly - no additional caching, especially since I’m using Cloudflare.

And tags like ‘cf-nel’ seem to refer quite clearly to Cloudflare - and nobody else. Especially when I run a Google search for these headers.

Time ago, one client have an issue with cache using Wordpress on Godaddy hosting. Is a news site, they don’t need a high level of cache. Investigating, I found that the problem was Godaddy. We just change hosting provider.
Maybe doesn’t appear in header tags, but maybe they have a cache mod. You can check with phpinfo();

That’s not the IP address of your origin server. You just tested it through Cloudflare again.

So you mean the server where the Wordpress instance is running?

hmmm… I’ll check by next week since I have no clue how to figure it out.

1 Like

It should be the “A” record in your DNS page here that points to your website.

@sdayman Little bit late - nevertheless … Now I have the IP-address from the DNS A record

Just to have a proper idea: when I connect with the

–connect-to 136.243.xx.xx

and get the same result as without using this option this means??? This means that the server has some cached version???

That is correct.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.