Pulseway and Cloudflare WARP

May I suggest Pulseway is added to IT Management or Collaboration (because of remote control) categories in the Cloudflare Gateway HTTP Policies?

I found two situations:

  1. On my desktop with WARP client trying to remote access dev machine, I couldn’t establish a remote control session with WARP enabled on the client desktop.
  2. Installed WARP on remote development VM with Pulseway Agent but the agent immediately disconnected so it showed as offline on my list afterwards.

If needed can provide more information with details to reproduce.

Hello! Categorization (or miscategorization) requests can be submitted to Cloudflare Radar.

If you’re seeing disconnection issues with WARP, that may be another issue. Are you seeing Pulseway get blocked in your Analytics → Gateway logs? If so, you can also add a policy to allow or block custom domains:

More information on these options can be found at https://developers.cloudflare.com/cloudflare-one/policies/filtering/dns-policies/policy-management.

Hi

Thanks for your reply. I am not talking about the website but the service itself - as used in the HTTP Policies here:

Pulseway is a remote administration/monitoring/management tool and it should be under one of the categories in that list.

The Pulseway Agent loses connection if Gateway WARP is used. It should be in one of the categories so we could create a “Do Not Inspect” policy to bypass if needed.

Hi @freitasm thanks for the feedback. Do you have a list of hostnames associated with Pulseway or documentation about what needs to be bypassed when using the agent behind and enterprise proxy?

1 Like

I am trying to find out… Will update later (will test with my own private rules first).

@pzimmerman an update with some partial results, while I keep testing.

I was provided a list of IP addresses I’ve added to split tunnel and that solved the problem with the Pulseway Agent on the dev VM server - it now stays connected to the Pulseway servers, which show the machine status as online.

On the client side though, still not able to establish a remote control session so waiting for them on anything else to diagnose this.

So 1/2 of the pieces are in place. Will update again later with list of IPs and domains/actions needed.