Publishing problem using RapidWeaver

I signed up to Cloudflare to acquire an SSL cert and went through the process seemingly successfully.
After changing nameservers to cloudflare to get the SSL cert I have had publishing issues.
I get duplicate thumbs when using www.
(The first link contains www the second link does not, same page.)

I see the issue if I access the page this way (with www):

From here, without the www, the page is correct from my end:

I have cleared the cache in all the browsers.
I can bring back the issue by adding www.

Changing the publishing settings in RW to www or not makes no difference.
It is only happening on the one page that I have published changes to since adding cloudflare.

Adding to my confusion, when I check https://www.tommurrayartist.com/galleries/sugarman/ in browsershots.org, the page loads correctly.
So it seems everywhere except on my computer the page is correct even using www in the address.

Notice the attachment showing double thumbs on a photo album page.

I’m not seeing any duplicates in Firefox or Brave (Chrome). I see your duplicates aren’t duplicating the captions, so it seems to be filename-based for the duplicate images.

Have you tried “Purge Everything” in the Cloudflare Cache settings page?

Yes Purge Everything then emptying the cache on my browsers has fixed it for now.
It remains a mystery why I was the only one seeing this problem.
I’ll wait and see what happens next time I publish a change.
Thanks.

2 Likes

I guess I will need to “Purge Everything” after every change to the website.