"Pseudo IPv4" = Overwrite, does not work for mobile

We use an analytics platform installed on our subdomain (matomo), and we have put the Network setting “Pseudo IPv4” to Overwrite - but the problem is that this doesnt work for Mobile devices. Their IP-addresses are still masked (All starts with 245.-248. and probably more). We have debugged alot and this is only true for mobile devices. Here’s someone else with the same issue: HTTP_X_FORWARDED_FOR incorrect - #4 by chucklin72 What can we do to fix this?

Hi there!

Pseudo IPv4 uses the Class E IPv4 address space to provide as many unique IPv4 addresses corresponding to IPv6 addresses as possible. It should cover the range that you are reporting.

And about the Cf-Connecting-IP header?

Can you give more details, or raise a support ticket to debug this?

Take care!

Hello AlphaK and thank you for your quick response!

Im using the “Pseudo IPv4”, which returns exactly this IP (from my mobile device):
248.19.42.72

But in reality, (whatismyip), my IP is 94.191.136.xxx

Am I expecting a result here which is not possible?

You almost certainly have an ipv6 address in addition to your ipv4 94.191.136.xxx address. The 248.19.42.72 is reflecting your ipv6 address.

Yes that’s what I figured. So there’s no way to actually get ahold of my 94.191.136.xxx-address then?

If your site is accessible via IPv6 (which Cloudflare orange cloud / proxied sites are regardless of the origin ip address), then it should be expected it may be hit from IPv6 addresses. Enterprise customers can disable the IPv6 address when proxied, but that’s probably a bit too expensive :stuck_out_tongue: (and excludes the small but real percentage of users who only have an IPv6 address).