Pseudo IPv4 Mismatch via CF-Connecting-IP

I have an issue where a third party that serves up an IFrame requires IPv4 but views the Pseudo IPv4 in CF-Connecting-IP as a mismatch in the data being sent. Not sure how to work around that. The vendor is not planning on supporting IPv6.

So you are forwarding the client’s address to the third party, who then responds with an IP-specific answer, which won’t match the actual address?

Your best option is probably to disable Pseudo IPv4 and handle the IPv6 addresses directly, of course the client would still need to use the same IPv6 address and not switch to IPv4.

Otherwise you could only upgrade to a paid plan and disable IPv6 altogether → Cloudflare API v4 Documentation

Is that only available via the API you posted and not via the UI?

There is a UI option, but only for Enterprise plans.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.