Proxying disabled after Dynamic DNS update

I’ve been noticing that my A records kept toggling off from Proxied to DNS Only on their own.
As luck would have it I’ve been able to correlate this to Dynamic DNS updates from my pfSense.
Two other A records I’ve stopped updating and remained proxied whilst the others that updated the IP got switched to DNS Only.
Any ideas how I might work around this?

1 Like

Something is triggering it. You can check from the Audit Log at the top of dash.cloudflare.com. It’s either:

  1. Someone logging into your account and making the change (not likely)
  2. Something using your API Key or Token and making these changes (extremely likely)

Indeed pfSense Dynamic DNS Service is using the API keys to update the records.
Out of caution I did not enable the Cloudflare proxy option on initial setup and forgot about it.
Hoping this helps out other noobs.

2 Likes

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.