Proxy or DNS only? Email not working when proxied

Long story short…switched email over to Google Workspace a few weeks ago and it has been a disaster just trying to get things back to normal. I moved out of Google Workspace so that is no longer the problem but Clouflare is fighting me on this one. Essentially when I moved out of Google Workspace, removed their records and went back to Cloudflare’s recommended records my email was completely broke. So my host suggested to change the email record to point to them and things started working. This is where the proxy question comes in…

During this whole mess (last week), I had changed all the proxied DNS over to DNS only because I was seeing a warning about it being “wrong” (and I was desperate to get things working). So the last week I have been not proxying anything but email has been working fine. Then today I get a report showing nothing has been going through Cloudfare (for this reason) so I decided to switch everything back to being proxied. But this, once again broke my email. Now I know before there were only a few that were DNS only where most were proxied. But not sure what is the right combination that I was using before. And surprisingly I can’t find any information on what should and shouldn’t be proxied. So I figured, since my mail was broke and wasn’t broke before changing the mail settings, maybe that is the issue. So changed them back to DNS only but still doesn’t work. Obviously I am doing something wrong. Currently have Cloudflare paused so I can get my email. Am I missing something obvious? Thanks in advance.


Thank you for asking.

I am sorry to hear you are experiencing an issue with receiving and/or sending e-mails while using Coudflare for your domain name.

Kindly, see below suggestions and tips for troubleshooting.

Make sure to switch from :orange: to :grey: (DNS-only) the next DNS records:

  • A cpanel, A cpcalendars, A cpcontacts, A mail, A webdisk

Furthermore, edit your MX mail and make sure you change it’s name to, therefore make sure it is pointed to

Usually, the MX record should point to a hostname such as mail , and the A (or CNAME ) type record for that hostname should be set to :grey: (DNS Only).

Furthermore, if you recently moved your domain to your Cloudflare account, I could try to troubleshoot at first sight without knowing anything other as it could be related to either:

  1. Wrongly setup e-mail related DNS records at the DNS tab of Cloudflare dashboard for your domain name
  2. Possibly missing some TXT /CNAME records (for SPF , DKIM, DMARC if so?)
  3. You are using a hostname like which is :orange: (proxied) rather than the unproxied :grey: (DNS-only) like (possible this one not existing or is :orange: instead of being :grey:) at the DNS tab of Cloudflare dashboard, in your e-mail client for sending/receiving server (MS Outlook, Mozilla Thunderbird, etc.)

May I suggest checking below article if your e-mail records (usually the A mail and the MX record) are configured properly while you are using Cloudflare for your domain name:

1 Like

I will have to work on this when I get back in town (next week). Too worried I will mess up something right before I leave and not have email while I’m gone. But yes, I had looked over those articles before posting on here. I have tried using the default mail settings Cloudflare recommends for my email (where it creates all the records), I have tried to change the settings recommended by host where it skips Cloudflare, and even tried to modify them per a few different instructions I seen online. But no matter what, whenever I unpause Cloudflare, my email is broken. I should note I have been using Cloudlfare without issue for about 5 years. Switching over to Google Workspaces really messed things up for me. I had a feeling it was a bad idea letting them control my business email but didn’t know it was going to be such a nightmare just trying to get things back to normal after leaving them.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.