Proxy my public IP address

Whenever I proxy my public IP address through Cloudflare on the DNS page. I can’t connect to my server ikebut.com ??

Whenever I proxy my public IP address ( 96.31.63.120 ) through Cloudflare on the DNS page. I can’t connect to my server ikebut.com .The only way I can connect to my website is by using my private IP address ( 192.168.1.3 )
I run my website from Apache 24 httpd

Please turn off the cloud and turn it back on

Greetings,

Thank you for asking.

DNSSEC is ok. Domain status is ok. Using Cloudflare ok.

From a lookup:

;QUESTION
ikebut.com. IN A
;ANSWER
ikebut.com. 300 IN A 192.168.1.3
ikebut.com. 300 IN A 96.xx.xx.xxx

192.168.1.3 → Should be removed. Or you’re using it actually somehow as a “temporary IP” for some kind of a Cloudflare Workers route maybe or only for Page Rules (I doubt, but I still ask)? :thinking:

96.xx.xx.xxx → Looks like an assigned IP from your local ISP. Should be replaced with your web hosting/server/origin host IP address. Except, you’re serving your Website from your own device from home network via router? :thinking:
If so, maybe your router doesn’t support and your ISP might be blocking some ports, therefore you cannot use port forwarding feature.

You could try with using cloudflared tunnel or some other port which might work, if that’s the case :thinking:

Kindly re-check if Cloudflare is allowed to connect to your origin host/server (be it Apache htaccess, some other firewall, switch, etc.) as follows in the below article:

Nevertheless, Cloudflare IP addresses list can be found here:

May I ask have you tried using a different Web browser, or tried clearing your Web browser cache?
How about using a Private window (Incognito mode) or a VPN connection if possible?
Is it the same behaviour on your mobile phone (4G LTE, mobile data, cellular)?

Before moving to Cloudflare, was your Website working over HTTPS connection?

Kindly, before doing anything at Cloudfalre settings, you could determine if you have a valid SSL certificate installed at the origin host/server by your web hosting provider or your own VPS/dedicated server following the steps from below:

  1. Use the “Pause Cloudflare on Site” option from the Overview tab for your domain at dash.cloudflare.com .
  2. The link is in the lower right corner of that page.
  3. Give it five minutes to take effect, then make sure site is working as expected with HTTPS.
  4. Check with your hosting provider / cPanel AutoSSL / ACME.sh / Certbot / Let’s Encrypt or some other and renew it accordingly.
  5. Only then should you un-pause Cloudflare and double-check your SSL/TLS setting to make sure it’s Full (Strict).

May I ask what SSL option have you got selected under the SSL/TLS tab at Cloudflare dashboard for your domain ( Flexible, Full, Full Strict … )?

Using curl, either something is blocking the connection, or host is down. However, I am also afraid you don’t have a valid origin SSL certificate installed for your domain name :thinking:

Here is a way to re-check if you correctly setup the SSL for your domain with Cloudflare:

In case you do not have an SSL certificate, you can use Cloudflare SSL, if so, kindly make sure you follow the instructions as follows on the below article to setup an SSL certificate using Cloudflare Origin CA Certificate:

Last but not least, kindly have a look here for more information regarding correct SSL settings at the SSL/TLS tab on Cloudflare dashboard:

I can’t connect to my HOST http://ikebut.com .
error -ikebut.com took too long to respond connection timed out
My IP: 96.31.63.120

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.