Proxy affects performance?

After a few days my website always slows down, sometimes it takes minutes before it pops up. Then I turn off the proxy or set developer mode on and it runs fast again.
The GTranslate subdomains don’t have this problem (no proxy set), only the source website.
Is it caching settings or SSL-certificate handshake?
Any suggestions?

Can you show a waterfall/HAR document or screenshot when this happens?

Also at the proxied site please append domain.tld /cdn-cgi/trace and post the result here

I did a reset this morning so we have to wait a few days. But when I look to the waterfall it always starts with a long period of waiting / server time.

Again: please show a screenshot so we can analyse it.

fl=20f272
h=www.itpedia.nl
ip=163.158.181.69
ts=1616060019.595
visit_scheme=https
uag=Mozilla/5.0 (Windows NT 6.1; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/89.0.4389.90 Safari/537.36
colo=AMS
http=http/3
loc=NL
tls=TLSv1.3
sni=plaintext
warp=off
gateway=off

There is no HAR file on the server. Which waterfall tool do you suggest?

The Waterfall in your Browsers Developer-Console (Network section) which shows the long connection time


Should I take another option to show?

Its the right Option, but the waterfall itself just shows responstimes from
12ms-41ms (which is very good)

Please hardreload the whole site (while Dev-Console open) and post the full result after this as it should show the long connection time



Like I said, the site is fast now, but before I turn the proxy off and on this morning it was very slow…

The proxy actually is turned ON and the site is fast. See the header:
image

cf-cache-status: DYNAMIC

This is a CloudFlare header which just gets shown if the domain is getting proxied.

Responstime (whily proxied) is at:


64ms!

I do not see a slow site

If the problem would be at CloudFlares site, the site would be consinstently be slow, not randomly!
I’m pretty sure the problem is not related to CloudFlare but to your Application (WordPress installation) or to your Server (Shared Hosting/VPS/Server)

1 Like

Yes, that was my thought too, but why would turning the proxy off / on have this effect? Because when the proxy is off (direct to the website) every thing runs fine…

Just like right now… everything is running fine aswell! And you are getting routed through CloudFlare.

Yes, that is puzzling me…for months now.

Anyway, I am planning to move to a VPS. Maybe that will help…

I think it is like this:

Your server is slow from time to time.

In general he is fast (with and without Cloudflare) but when he is slow you recognize this while using CloudFlare, but as soon as you recognized it (like because of a cach flush) you warmed the cach back up with the request you realized it took long.

Then you try it without proxy and it seems to be fast again… but there you miss the point that it also is again fast with proxy.

So as the site now is fast with and without proxy I would recommend you looking into your server/hosting/application and turning on higher debug level to debug the whole thing.

If you are on Shared hosting or on VPS please notice that you share a connection with other users which may abuse the connectin and therefore make your server not beeing able to respond fast. (with and without proxy)

If you are on a dedicated Server with a dedicated connection/bandwith which is not shared with others things are differently.

But as you see right now: it can not be related to CloudFlare, bc if it would be it would also now be slow now, but indeed the TTFB is at 64ms.

Ok, I can follow your thinking and you are probably right. I had resource problems with this server in the past, but they changed that to another protocol. Maybe the effects of the new settings are shown in slowness. In a few weeks I’ll have more time to work it out. Thanks for thinking with me.

You are welcome!

Just make sure that if you encounter a slow proxied site in the future you can capture it in a Waterfall screenshot so we can debug it.

:+1: Dough I am 62, I learn everyday!

1 Like