Proxy A Record Not Working When Using Pages

Hey friends, I’m not an expert in DNS so I may just be doing something obviously wrong but I set an A record on one of my domains to point to a different server and it doesn’t seem to be working. When I do a DNS lookup I do not see this A record, even after waiting 48 hours.

I suspect it is because I have a Cloudflare Pages deployment set up on a subdomain. Perhaps I’m missing something? I’ve done this countless times for other domains and it worked fine but never in conjunction with pages.

My goal is to have the domain point at for and while having point at the Cloudflare Pages deployment.

Here is a screenshot of my DNS config. works perfectly while just shows an error and when I do a DNS lookup it shows different A records than I have configured:

Thanks for any advice. I am sure I’m doing something obviously silly. :slight_smile:

What happens when you set those two names to :grey: DNS Only? When you disable the proxy on both the apex and www names are you able to reach the site on your origin server as expected?

It is not due to Pages :slight_smile:

It looks like it is working though, visiting that domain gives me:

Error. Page cannot be displayed. Please contact your service provider for more details. (31)

That is coming from your origin server.

The reason the IP address isn’t what you expect on external sites/dig is because of the orange cloud, we are proxying the request. So instead, you see Cloudflare IPs.
You can read more about that here: Proxy status · Cloudflare DNS docs

1 Like

Interesting, but if thats the case why doesn’t a DNS lookup show the correct IP? I’d also add that the origin server just throws an error when I try to setup the domain saying that the A record is incorrect. There must be something I’m doing wrong on the Cloudflare end that would cause the A record as configured to not actually show up in public DNS records?

Presumably, if it was working as intended the DNS lookup ould return an A record pointing to as configured would it not?

Check the bottom of my last post :slight_smile:
This is normal for proxying with Cloudflare, the requests need to go through us so they have our IP. You can orange click the record to not go through Cloudflare
Click “Edit” on the record then set to “DNS Only”:

1 Like

Thanks. This makes sense and worked, I knew I messed up something simple and obvious!

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.