Proxmox tunnel issue

I get a host error. The thing is that I’m hosting my server using Proxmox and the IP address changed but now I can’t seem to change my IP address and port. The IP address has the port of :8006 but Cloudflare doesn’t allow me to enter the port, please help.


Could you describe your setup in a little more detail? You mentioned Tunnel in the subject/title, but from what I can tell it seems like you’re only using the proxy.

Do you have cloudflared installed somewhere?
Are you using ZT Tunnels?
The IP of what object changed? (probably not proxmox, it’s set static by default)

Any additional information can help me determine what’s going on with this.

1 Like

This makes no sense why I cannot simply change my IP address Brandon. I paid for a domain from cloudflare I cannot use. Seems like VPNs are a better and much simpler choice to do something like connect to Proxmox. Do I need to install a new tunnel script into Proxmox? I tried having my proxmox forward fro port 8006 to 443 to see if that works for Cloudflare, it didn’t :face_exhaling:. It works however on my home network if I go to my IP with the 443 port at the end… Sheesh. I want to do something seemingly so simple and support is practically non-existent unless your willing to fork out $200 for some business plan. Nevermind I paid for the useless domain. I had a lot of hope in Cloudflare but that bridge has almost burned! Change my mind!

The unfortunate truth about most ISP’s is that they do rotate IPs occasionally. Sadly, that means extra work for people like you and me, who just want our services to work.

I’ve taken a look at your configuration. Your tunnel exists, it’s healthy, and there is a Public Hostname pointed at the Proxmox IP which I assume is up to date.

When you made the tunnel and inserted the Public Hostname, it created a DNS Record specifically for that entry. That alone should have been enough to withstand your ISP changing your public IP, but it looks like that record was changed.

We need to change it back. If you go to Zero Trust > Network > Tunnels, you should see a Tunnel ID. Copy that ID, then go back to DNS Records.
Change the domain name record back to a CNAME, and paste in the Tunnel ID for Target, then append

What you should end up with is something similar to this example:

After you save it, you should be able to use, simply, https://domain.tld - with no ports - and get to Proxmox.

Let me know how that works. I’m here to help till it’s done, so let’s work together on this.

You can also come to the Cloudflare Developers Discord and ping me there @cfbrandon: Cloudflare Developers

1 Like

Here is exactly how I setup my Proxmox to Cloudflare. I watched this guys video via YouTube, it’s a short video perhaps you can check it out and then you will have a better understanding of my situation because I’m bad with cloud hosting services and cloud networking, here’s the link:

That video is exactly right, if a little outdated. If you followed that video step for step, you’ve done things correctly. The problem is that he does not go over what that process does to the DNS records.

Seeing as how it was not brought up, I can understand why you may have thought the DNS Record needed to be changed. What I’m saying is that the current DNS Record content (consisting of an IP in your network) is incorrect and needs to be set back to what Zero Trust configured for you.

In my previous response, I’ve provided you the instructions to set it back and get it working again. Please follow those instructions and let me know what happens.

1 Like

Im going to try your instructions now…

Hey okay I followed your instructions and now I get an error still when attempting to go to (see the photos). Can you tell me if I did something wrong here? I copied the ID and appended exactly what you told me…

“Name” should be @ - this will evaluate to
The Target field receives what you put into the Name field.

1 Like

Trying that now Brandon and I’ll let you know how that goes, but everything else looks right?

Everything else looks OK to me. You might need to tweak the public hostname, but we’ll see how that looks after you test.

Just for visual reference, this is what you should have:
(edit: do not post your full tunnel URL here, for privacy)

Name: @
Content: <not visible>

1 Like

I did this, and saved and it propagated under Name but now I get nothing at all when going to :pensive:

Am I just a moron or is there something I truly messed up bad?

No, I’m having the same issue now, with the Gateway 502 error. My setup is a bit different, I’m running everything internal through NGINX Proxy Manager.

I’m checking some of the Public Hostname settings to see what gets it to work. You can see mine now, it just comes up with a blank page:

Allow me some time to work on this and I’ll get back to you. Again, if you are in the Cloudflare Developers Discord, we can work on this in real time as well: Cloudflare Developers

1 Like

Should I just start over? Erase everything or delete the entire DNS record…? Can I keep my domain name? I purchased it from Cloudflare and it doesn’t expire for quite some time…
Please let me know what you’d do in this situation…

Just saw your response, okay I’ll give it a day to see if it works itself out. I will be in touch tmr afternoon and head also to Cloudflare Developers and see if I can get my sad unused server up and going again through Cloudflare. Thank you for all you’ve done today, I feel I’m making some progress in understanding this process, although fairly new to using cloud infrastructure and tunnels I hope together with your help this can be resolved and I learn so I’m better equipped to resolve any issues I have in the future. Till tmr, Brandon, take care. :slight_smile:

Well man, same thing, cant reach my Proxmox…I feel like just starting over from scratch but also I know if this ever happens again I will be in the same shape, so I’d like to resolve it and understand the issue at hand.

Where can I go from here Brandon??? What can I try next to recover my Proxmox tunnel???

You quit on me @CFBrandon ?