Proxied site not available using Serverpilot, Let's Encrypt, and Cloudflare

I have a site using Serverpilot with SSL enabled using their AutoSSL. The site works fine and is accessible via https when Cloudflare is disabled (grey cloud). However when enabling Cloudflare, the site is not accessible, and I see a page with the following error:

Secure Connection Failed

This site can’t provide a secure connection

If tried toggling the SSL settings between off/flexible/full but that hasn’t helped.


Search for these error codes here. The certificate on the proxied wont have issued yet. The articles you will find will also tell you what to do in this case.

Whats the domain?

1 Like

Thanks @sandro

I’ve been reading the forums and cant find a solution. Most people seem to toggle SSL from flexible/full, but that hasn’t worked for me.


You dont change your encryption mode (which should always be Full Strict), you should toggle Universal SSL altogether and wait 30 minutes inbetween.

that seems to have fixed it. thanks!

1 Like

This topic was automatically closed after 30 days. New replies are no longer allowed.