Proxied services not available on IPv6, could be breaking connectivity for NAT64 users

Hello! Before starting I would like to state that I am not a Cloudflare customer. While I have an account, it’s free and has literally nothing on it. I’m reporting what is an issue that 2 other customers have experienced and affects me as an user.

I was on youtube.com when I noticed that one of the extensions I use (returnyoutubedislike.com) just started to not work on IPv6-only / I was using IPv4 even though it always used IPv6 before.

Decided to report it also realizing that another service (SponsorBlock) has the same issue of not having IPv6 connectivity, figuring out that it actually does have it and that it’s through Cloudflare and that to me, and to some locations all over the world, it wasn’t working.

I can’t confirm but my understanding is that this breaks NAT64, because it seems as if DNS64 only tries to convert A records into AAAA ones when there’s no AAAA ones, since those IPv6 connections aren’t reacheable, it would just think it’s down.

These services are proxied.

I don’t actually understand what’s going on here and what the issue here is, but in short, services proxied through Cloudflare don’t seem to have IPv6 connectivity in certain locations.

I will leave some Discord screenshots on which the devs & community for these services discussed a bit about it, until now I left it just on hold because I thought it was gonna get solved, but it has been 5 days and nothing, and since this could be breaking some NAT64, well thought it was important.







If any tests I can do can be helpful, I can send you those, I’ll be checking on this thread every once and a while.

Here’s some tests that I believe can help figure out whats happening, these were done just now as I’m posting this.

I was gonna try tracert, but that just worked on IPv6, even though the last IP address just wouldn’t connect not even give me that “Direct IP not allowed” screen when putting that on the browser. Oh, the IP is 2606:4700:e0::ac40:6617 by the way.


Also now returnyoutubedislike.com no longer has an AAAA anymore, so if anyone is to focus on a specific service to solve this issue, use SponsorBlock.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.