Proxied round robin points every time on first IP

Hello, I have quite weird problem here.
I have two ISPs and I have added two A records for my two public IPs for RR.
However when my main ISP drops down (first in the list), CF won’t route traffic to my second IP. I am getting Error 523 and 522.
But something still arrives to my router:

tcpdump -ni eth1 host 104.21.4.198:

tcpdump: verbose output suppressed, use -v or -vv for full protocol decode
listening on eth1, link-type EN10MB (Ethernet), capture size 262144 bytes
18:37:45.270235 IP 172.30.120.138.60022 > 104.21.4.198.443: Flags [S], seq 1000505735, win 64240, options [mss 1460,sackOK,TS val 4142801614 ecr 0,nop,wscale 7], length 0
18:37:45.281544 IP 104.21.4.198.443 > 172.30.120.138.60022: Flags [S.], seq 1401979015, ack 1000505736, win 65535, options [mss 1400,nop,nop,sackOK,nop,wscale 10], length 0
18:37:45.282240 IP 172.30.120.138.60022 > 104.21.4.198.443: Flags [.], ack 1, win 502, length 0
18:37:45.305994 IP 104.21.4.198.443 > 172.30.120.138.60022: Flags [.], ack 518, win 66, length 0
18:37:45.350911 IP 172.30.120.138.60022 > 104.21.4.198.443: Flags [F.], seq 848, ack 3734, win 501, length 0
18:37:45.361668 IP 104.21.4.198.443 > 172.30.120.138.60022: Flags [F.], seq 3734, ack 848, win 67, length 0

and that’s all, nothig goes back.
When I tried to remove my main ISP (currently offline IP), it started working normally - so my IP is right.
But as soon as I added that IP again, it again showed just 523.
I also tried to “Pause CF for my domain” so my browser tried RR itself - and it worked too. So I assume there must be something wrong with proxied RR.

Don’t you have any idea why this might be happening and if I can do anything? Or is this normal behavior and I have to get LB? From what I’ve read on this forum I guess it’s working fine for others?

Thank you in advance.

Cloudflare really doesn’t do Round Robin unless you’re using the Load Balancer product. One IP address of a duplicate set in DNS is selected randomly at the edge then used for a while. On paid plans, if one address doesn’t respond, it will fail over to the other one.

2 Likes

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.