Proxied option not available for CNAME flattening

Trying to setup CNAME flattening for a domain root to point to a load balanced proxy URL with multiple IP Addresses (WPEngine GES) but I’m only given the option for “DNS only” so I can’t enable the “Proxied” option making most of the CloudFlare services obsolete.

How does the DNS configuration tool determine that I can only have “DNS Only”?

Is there anyway to configure CloudFlare DNS to use a Proxied configuration with CNAME flattening targeting a proxy URL with multiple IP addresses?

Typically you can’t proxy Cloudflare IP addresses, though this usually shows an error and does not prohibit proxying.

Post a screenshot of the CNAME record in question.

Also flattening is only relevant in a non-proxied context. Proxied records are A records by default.

I can configure other CNAME entries as Proxied in CloudFlare DNS just not the entries targeting xxxx.wpeproxy.com for the WPengine GES service. I can select Proxied when adding the CNAME but it reverts to DNS Only when saved, then when I try and edit it doesn’t give the option for Proxied anymore.


So according to wpengine support the wpengine GES service is a CloudFlare proxy so CloudFlare DNS knows not configure a CNAME as proxied when targetting another CloudFlare proxy