Proxied option causing traffic to not make it to my kubernetes cluster

Hello! When I turn the “proxied” option on in my domains DNS settings it stops traffic from being able to hit my Kubernetes cluster… (it does work on DNS only). I was curious if someone had a idea on what I need to configure/change to allow traffic