Proxied DNS records return origin server IP

Dear Community,

For a couple of days I am trying to setup MTA-STS for my domain. Since Cloudflare does not support this natively (yet :wink:), I am trying to set it up via a worker. The worker works fine, if called directly.
However, the worker route never gets triggered.

Until further investigation, I think I found the issue:

  • I have 1x A record and 1x AAAA record set to and 100:: respectively
  • Proxying IS enabled
  • the origin IP is returned instead of a Cloudflare one, as I would expect with proxying

Any thoughts on why it behaves this way?

I have setup multiple HTTP redirects from other domains that way and they work perfectly fine. Only my main domain does not proxy these records correctly / at all.


Sounds like that zone is not active on Cloudflare.

Can you please elaborate?

As far as I understand Cloudflare:

  1. zone = domain / site;
  2. subdomains - aka A and CNAMER records - are setup in the same site; only exception: Enterprise plan where you can add a subdomain as site directly to the account

regarding 1: it’s setup as site in Cloudflare
regarding 2: it’s an A record under the root site. Does a worker route only apply to the root - 2nd level - domain?

now I am totally confused: it seems that none of the records are proxied, even though Dashboard shows they are “orange”. :open_mouth::face_with_raised_eyebrow::thinking:

Maybe delete the site in Cloudflare and start from scratch? :tired_face:

It sounds like you Paused your site on Cloudflare. This would show up at the top of your Overview page in the dashboard.


Thanks for that! Yes it was. I never look on the overview page and there is no notification on the DNS or any other page, which might be affected by this setting. :face_in_clouds:

I was going crazy over here. Typical case of Error 30: the error sits 30 cm in front of the keyboard. :sweat_smile:


This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.