"Property is receiving data from redundant hostnames"

Hello,

I can’t find a solution to the problem I’m facing.
Google Analytics found an error (redirects) that I can’t handle and maybe it’s some kind of glitch on your part (see attachment).

On my side, everything looks fine and on the hosting in Nginx, the code responsible for domain redirects is registered.

I have selected the option with " WWW”:

www rewrite

RewriteCond %{HTTP_HOST} !^www.(.) [NC]
RewriteRule ^(.
)$ http://www.%{HTTP_HOST}/$1 [R=301,L]

I do not know how to get rid of this problem, which may be related to the Cloudfare.

I got advice from Google Domains support:

I see. For this, I highly suggest reaching out cloudfare. Just to let you know, if you’re using their Name servers, there is no redirect happening under Google Domains (your DNS settings) as the DNS is currently disabled due to using Cloud Name servers.
That means, your DNS host right now is Cloudfare.

You may try contacting them to check the redirects as it is directly connected to them by using their Name servers.

I would really love to help you with this, but as I checked your account here, I do not see any issue from it. This is also something that we do not cover anymore regarding on analytics so I am afraid.
Let me guide you on how to contact them instead.

So to contact them, you may go to this link Cloudflare Help Center, scroll down at the bottom and you’ll see a contact number indicated there.

I can not see any error on your redirects. So there are many possible situations you have run in.

Anyway there is somethiong I would improve:

Please directly redirect to HTTPS, instead forst to HTTP://www then to HTTPS://www.
As otherwise you will have 2 redirects instead of one:

These redirects also can be done with PageRules at CloudFlare so they do not need to be done on your origin server.

But as far as now everything is working fine and you at least should not receive any NEW data from redundant hostnames.
So I would recommend inspecting that the next days and report back then as for now everything works as it should.

Thank you for your answer.
Please take a look

Here you start with HTTPS already. To test it completely you will have to start with:
http://rubberloft.com/

So with HTTP and NON-WWW

Hi,

Pay attention to your first message, where they said that the redirect should be direct from https:// to https://www

Sorry for not making this very clear. Actually there should be 3 redirects:

How I described here:

Just have a read. But yes, also HTTPS should redirect to HTTPS://WWW.

Ok, now I have:

![imag

Sorry, I have like that

Correct! now everything is redirecting correct. Just give Google some time to realise that and realise there is no traffic comming from any redundant hostname anymore.

Hello again.

After making the changes that you recommended, the traffic began to decline, maybe a mistake was made somewhere? Could you also tell us about DNS, maybe there is a problem there?

What should I tell you about DNS? Just ask I will explain it to you, but on DNS level there should be nothing that could have gone wrong.

As soon as all DNS entries which are required are set and are properly redirected everything will (should) work fine.

I only assumed based on how I was informed in Google Domains. I cited this above

I highly suggest reaching out cloudfare. Just to let you know, if you’re using their Name servers, there is no redirect happening under Google Domains (your DNS settings) as the DNS is currently disabled due to using Cloud Name servers.
That means, your DNS host right now is Cloudfare.

You may try contacting them to check the redirects as it is directly connected to them by using their Name servers.

This basically just means that Google can not help you there because you are managing your site at CloudFlare now and not at their DNS

BUt even if you would use their DNS they would not have helped you as they stated on their own:

But there is no problem anymore as far as I can see, so nothing to do, not with Redirects NOR on DNS level.

Ok, thank you for your support.

Hi again,

Sorry, I forgot to ask you one more question:
Why does the redirect occur with the intermediate code 204?
What is the reason for this result?
This happens on all types of domains when redirecting.

You can look up the meaning of every HTTP response Status Code here:
https://developer.mozilla.org/en-US/docs/Web/HTTP/Status

204

stands for “No Content”

Yes, but my question is how to get rid of this intermediate code, so that it is not there at all?

If something happens you dont know please follow this list:

  1. first please analyse and understand what it does and why it is there.
  2. when you know what it is decide if it is “bad” or “good”
  3. if its good, let it stay there
  4. if its bad change it

But we not even completed step 1 and you already judge :smiley:

Let me take you by the hand and take you on a journey of debugging where this comes from and what it does.
So to find this request we call your site and check the network tab:

There are many more requests but we are lazy and dont want to search, so we sort them by “Status Code”. We do this by clicking at “Status”:

Now you will see some requests with a Status Code 204.
These are our your request! We inspect them and find out.

  1. one has this in its path: /cdn-cgi/beacon/performance
  2. two others has this in their paths: https://pagead2.googlesyndication.com/pagead/
    So we just google this and the first result is this link:
    Cloudflare Browser Insights – Cloudflare Help Center

We read the page and see its about “Cloudflare Browser Insights”. So it is very likely to be related to Cloudflares Browser Insights function.

The other one we can judge based on its name. It must be related to Google AdSense.

Now we know why it is there, but we actually do not know why it is a 204 and not anything else.
Therefore we again look at Mozillas explanationpage for the 204 and see:

The HTTP 204 No Content success status response code indicates that a request has succeeded, but that the client doesn’t need to navigate away from its current page.

And we see that makes perfectly sense as we do not need any content to be delivered at a tracking URL but we still dont want to redirect the request as there is no need for.

We come to the conclusion that this 204 Status is very wisely chosen and is just perfect for this situation! CloudFlare (and also Google) have done a good job and implemented this in a proper way.

Now as we know where it comes and why it is a 204 Status you are one step ahead as you know how you can turn that off. By turning off Browser Insights and removing AdSense :slight_smile:
But the main question is: do you want to turn it off? And if yes, just because it correctly responds with a 204 Status Code?

3 Likes

You wrote everything perfectly and legibly :blush:
If the use of this code does not harm the page requests, then of course there is no point in getting rid of it. Just using the example of other resources of the same subject as my store was discovered by me without this intermediate code (204) and I wondered if in my case it should not be either.