Product feed not syncing


I am using to optimize my product feed. My feed is produced in woocommerce and shoptimised is meant to pull it in - this isn’t working. When I pause Cloudflare on the site it syncs fine! I have added oage rules, the IPs of shoptimised, I’m not sure what else to try - any ideas?

Shoptimised said they see the following in the HTTP header (this was before I added the IP addresses though):

[“HTTP/1.1 500 Internal Server Error”,
“Date: Mon, 07 Feb 2022 14:03:19 GMT”,
“Content-Type: text/html; charset=UTF-8”,
“Connection: close”, “X-Frame-Options: SAMEORIGIN”,
“Referrer-Policy: same-origin”,
“Cache-Control: private, max-age=0, no-store, no-cache, must-revalidate, post-check=0, pre-check=0”,
“Expires: Thu, 01 Jan 1970 00:00:01 GMT”,
“CF-RAY: 6d9d29381eb48897-LHR”,
“Server: Cloudflare”]


Thank you for asking.

I am not aware of them, but may I ask do they have some IP, user-agent or anything related which you could “allow” and “whitelist” at Cloudflare? :thinking:

Do you see any blocked or challenged request from them when you navigat to the Firewall tab → Overview of Cloudflare dashboard for your domain name?

Do they use some API or?

Maybe Bot Fight Mode has restricted them or something else might be in a way.

Thanks for replying!

It says allowed, but it is still failing to sync (when I pause Cloudflare it works straight away)

I hope the screenshots help?

Bot foght mode blocked my Square payments from working so I disabled it. Shoptimised access the file using the following php function:


Thank you for feedback information and sharing screenshot for help.

Sorry to hear this :confused: Happens sometimes. Good you’ve figured it out so far.

Good :+1:

Hm :thinking:

How do I request more help with this?

Still need help! How do I contact support? Sync works when I pause Cloudflare on my site - breaks again as soon as it is turned back on :frowning: