Problems wth txt mail record

After installing Cloudflare my site want send out emails. Ive tried using a txt record with content: @ v=spf1 include:domain.com ~all, but without any result. Cloudflare did pick up my mx records from the mailserver provider as a DNS(not proxy) so all I have done is to include the txt record mention above. The web- and mailserver are not the same provider but that shouldnt be a problem?

Have I done anything wrong? and should the @ be in the content, or can i just put in the name for root?

Best regards

If CF pick up your MX records from old DNS provider, then your mail settings are saved and running on Cloudflare Network by default. If previously you have all worked without problems, then when you transfer to us it should work further.

Hi,

Thanks for your answer Asobase. I have no idea what this could be.

But then I dont need to use a txt record with spf?
So strange. Worked for 15 min and then it stoped.

Best regards

I’ve no idea what your server still is - not was - as all properties of your “prior server” stay the same; this is why all records must be correctly set.

I use ProtonMail and this is exactly what my SPF record is:

(It - the domain - stays the same as your mail provider; it’s not changed to your domain. And note the missing mx prior to ~all in your SPF record as well as the missing _ after include:.)

v=spf1 include:_spf.protonmail.ch mx ~all

Thanks :slight_smile:

My mail server is tornado.email, so the record should then be?

v=spf1 include:_spf.tornado.email mx ~all

But if Iunderstand you right, this record should not be nececary becauce CF found the mx record for the mailserver when installing?

Best regards

It is necessary; let us know if it works for you.

(Attachment publicKey - [email protected] - dbd0a5f5e3cc2e74e9570c13d574c382305cd5fe.asc is missing)

Hi,

I tried to insert the txt record, but still doesnt work.

I recieved to mx records for the mail server when I added the site. Both dns records without proxy. Only the nameservers for the mailserver.

I have aslo added one TXT records:

Type :TXT

Name : the name of the webdomain

Content: v=spf1 include:_spf.tornado.email mx ~all

But i still dont recieve any mail. Something wrong with my setup?

Best regards

IT WORKS!! :))))

Thank you for your support. Couldnt done this without you. Thanks again :))

Best regards

1 Like

Apologies for my delay in responding - you are quite welcome. Happy to have helped! :slightly_smiling_face:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.