Problems with WEBP images: Polish does not convert all of our images

The problem is the following, the Polish function does not convert all our images into WEBP and therefore we are experiencing losses in organic searches. Someone who could advise us on solving this problem.

We have .jpg / .jpeg images but it only converts PNGs. How we solve the .jpg / .jpeg.

Thanks

May i ask which settings you have set polish to?
Lossy? Lossless?

Lossless is often not converting as lossless WebP images are sometimes bigger then the sourceimage and therefore will not be converted. Original PNGs often by default are not optimized at all and chances they then are smaller with WebP (even with lossless settings) are higher.

I would recommend changing settings to lossy.

If you can provide a link/domain we could take a look into.

Without loss we have it configured Polish

Previously we used CDN only for the images and in the URLs it always appeared .webp now it is impossible, we do not know what to do more :frowning:

We have configured with loss in Polish

As Cloudflare is a reverse proxy CDN it will not modify any URLs by default but change the MIME-Type (which is set in the header as “content-type”). You can easily look it up under the “Network” tab in you developertools in your browser.

See:

Header explained:

cf-bgj: Polish settings = 100% quality = lossless
content-type: shows the real format of the file

This actually means your current settings are set to “Lossless”
and not to:

Maybe you even have to purge cache for it to take effect.

We have already established it, if we are lucky this time. One question, and with all the images we have on our server, are they automatically converted before they are delivered?

Yes and no. The very first request from each POP (or if its a “MISS” in cache) will always just forward the original image for performance reasons.
But the second request will then (if the converted file is smaller) deliver the converted file.

And how can we guarantee that webp images are always sent? Do we need to install any plugin on our site? Previously we had Smush Pro but one of his colleagues told us that it was not necessary, CloudFlare did all the work. Sorry we’re lost :frowning:

Thats not possible with Cloudflare and sometimes not even positive.

There are two things like i said that prevent the WebP from beeing served:

  1. it is bigger then the original
  2. its a miss in cache on the POP

Reason1:
That makes absolutely sense! A bigger image should not be served, thanks god Cloudflare does this automatically

Reason2:
just make sure you dont purge cache for images too often. TTL is automatically set to 1 year as you can see in your header. That means once one single person requested it it will stay 1 year in its browsers Cache and about 1 month at Cloudflares edge cache.

You dont need to install or change anything, Cloudflare will do EVERYTHING for you automatically as long as you have a Pro Plan and Polish enabled. :slight_smile:
Please just wipe all cache right now to make “Polish lossy” take effect.

We have already purged the chache and we have enabled “with loss”. Hopefully with this we can solve the problem.

Yes, already working

Beside 2 Images all jpe?g images are now WebP

Thank you very much for your kindness, you are very nice.

You are very welcome, and also welcome to the community :slight_smile:

1 Like

We hope we don’t have any more problems with Google because of the images, that had us very nervous :slight_smile:

Indeed ALL the image optimization problems are gone:


(ofc some other problems are still here, but Cloudflare removed all related to “image optimization”)

The only image problem left is resizing, so serving the correct size, which the Cloudflare feature “Image Resizing” will solve:

But I guess thats included since Business Plan.

We have already enabled it days ago :slight_smile:

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.