Problems with subdomains. Urgent

I have been configuring Cloudflare for 10 hours. The domain works correctly but the subdomains do not. I have read the forum but I can not find the solution.

This is the domain and the subdomains are the diferents lenguages.

https://www.websincloud.com/

Thanks.

These hostnames are two levels beneath the domain (www.activities.DOMAIN) and this configuration does not work on HTTPS with Cloudflare. You have three options

  1. Remove the www in front of all of them.
  2. Switch off HTTPS and use them with plain HTTP
  3. Purchase a dedicated $10/month certificate from Cloudflare and add all the hostnames to that certificate

Also, regardless of which option you choose, you have to set up the records in the first place. They seem to be missing entirely from your DNS configuration.

1 Like

I turn off https from Cloudflare. But I also have an active Cpanel certificate. Should I turn it off too?

No, as long as your site is reachable via HTTP turning off HTTPS on Cloudflare should be enough. Again, you need the records in your DNS settings.

The DNS configuration records I think are correct. I do not know what he’s talking about.
Thanks

When you turn off https now also the main domain has stopped loading.
I do not know how to solve it.

It stopped loading because your force a redirect to HTTPS on your server and that enters a loop in this case. You need to remove that redirect if you want to use HTTP.

As for the records, the ones I checked did not exist.

First. I think I’m going to acquire the Cloudflare certificate to continue using https.
What I do not understand is the subject of the records. Unless it’s something I do not know. What do you mean, exactly?

Go to your DNS configuration on Cloudflare and check that you have matching records for all those language addresses you have on your main page.

I got them. 10 languages, unless I miss it.
Another question I have is if you can activate the cache for the 10 subdomains in the rules, it would be like this: * .websincloud.com / * , is it correct?

You’d need an entry for each host. Possibly www.*.websincloud.com but I cant guarantee this right now, you might have to specify them individually.

Where did you set them up? Can you post a screenshot? They still dont resolve.

I have already acquired the certificate, now I should go correctly, right?

They are not set up with www in front of them.

So should I do them: www.activities?

Well, thats what you wanted and the whole point why you got the certificate, right?

I mean the dns area, are they well created? or should I create them with www in front

Yes, as you want them reachable with a www in front of them you will have to add this to their names.

It is right? it still does not load

Now it is set up but you still have a certificate issue. Post a full screenshot of your Crypto page.