Problems with Email Routing not working

I am having a problem with email routing now. I have transferred 6 Domains to Cloudflare and did the exact same thing with all of them to route emails and 3 worked fine but the other 3 won’t route for them.

With the 3 that aren’t working, the Email Routing Overview shows that Cloudflare received each one but shows the Result as Delivery Failed for each of them, even though all of them, including the ones that are working, are routing to the same email address for it.

I did the exacts same procedure for the 3 that worked fine, where I deleted the MX and TXT records that Cloudflare required and I then had Cloudflare Automatically add the MX and TXT records to it.

It I compare the DNS between the domains that worked and the ones that aren’t working, they have exactly the same MX and TXT records for each of them, with the only difference being the Priority numbers for the MX records.

I tried deleting the routing rules and adding them again. But that didn’t work for it.

Did anyone else have a similar problem with it.

This is what it is saying the problem is with it.

Are you still encountering this issue @meier?

I am still having the issue with it.

1 Like

Is this being routed through gmail?

Well they are being routed to A2 Hosting where my email is hosted with. I am not using Gmail for it.

And A2 confirmed the emails are bouncing back from Cloudflare and that there isn’t anything being forwarded to my email hosted with A2 because it had already bounced back from Cloudflare.

The other domains I mentioned that are working, do route to A2 to the same email without any problems.

So I don’t know why the other ones aren’t routing properly to it, espcially since they have the same settings for it then.

1 Like

Thank you, I have flagged your post for the attention of my colleagues here on the Community, I also added a link and am cc’d on your ticket 2717942. If the team needs to communicate with your privately they’ll do so on the ticket, otherwise we’ll try to resolve the issue here.

I have reached out in ticket 2717942 and can assist you there.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.