Problems installing origin certs on nginx

I have followed the tutorial for installing origin certificates on nginx. But when i put the cloudflare security to full (strict) nothing happens, I get a 522 error.

I have waited for 24 hrs and still the 522 error appears.

Where am i going wrong?

P.S. www.life-at-sea.net

Do you mean that if you switch to Full SSL mode, you won’t get error 522?

Generally error 522 is not related to SSL issues, instead it means Connection Timed Out.

If i put it on full ssl mode i get a 522 error

Try pausing the Cloudflare service - under Overview tab:
image

Wait for few minutes, then try to access the website via HTTPS.

Share your results.

site can not be reached.

If i put it on flexible i get the error that the site does not have a correct pass through.

removed all of the sll shizzle from the conf file and put system on flexible and everything is now working again. But still not full and strict security. Somewhere I miss something. But what, I even port fowarded port 443. but still no results.

It’s no longer displaying Cloudflare error page right?

You might need to check the port 443 connection again.

Correct, the page is for now back to the flexible plan. And i have to figure out why port 443 is not open or something like that.

1 Like

This topic was automatically closed after 30 days. New replies are no longer allowed.