Problems connecting DNS records

Why Wait
Don’t wait for an answer, find it fast! Search for #CommunityTip error:
Example: #CommunityTip 521

I am still not able to connect my website to the name servers - I was trying all day yesterday. I think I have the A records filled out correctly, but I still get this message on my website hosting site: “This domain does not have the proper DNS A record configuration as outlined above.”

Thanks for any help!


Welcome to the Cloudflare Community, Barbara. :logodrop:

TL:DR; switch the :orange::grey: while your host checks your work

When you add your website to Cloudflare the A record will be :orange: Proxied by default. This means that visitors will connect to the Cloudflare Proxy which in turn passes along requests to your origin server. In order for the visitors to know that they need to connect to the Cloudflare Proxy, the IP address returned for your A record is one that is used by Cloudflare rather than the one used by your origin server.

If your origin server is trying to check your work with a DNS query for your A record, it expects to see its own IP, not the one used by Cloudflare. You can set that A record to :grey: DNS Only and Cloudflare will return your origin server IP. This should allow your origin server to find the IP it is looking for. Once it has completed its verification, you may be able to resume using the :orange: Proxy.

Thanks so much for answering so quickly - I appreciate it!

Do I change all the records to DNS only for now? See my screen cap below - I’m assuming they all have to be changed for the connection to take place, and then I change them back?

Again, thanks!


Is there a specific reason that have a wildcard hostname *? That will match any sequence of characters to the left of your domain name and doesn’t seem terribly useful. It is not without potential negative consequences, wither. Unless you have an articulable reason for that record, I would lose it altogether.

You will need to set the mail hostname to :grey: DNS Only in perpetuity. The Cloudflare proxy does not work with email protocols and leaving that :orange: will disrupt email traffic.

The other two records will need to be :grey: at least until the Plesk system decides to set up your domain on that server. You should be able to able to set them back to :orange: afterward, but I don’t work with Plesk to know firsthand.

Being very non-tech-savvy, I have to say I’m not sure why that * is there - I don’t think I entered it.If I did, I have no idea why I did now.

Thanks for the advice on the mail hostname - I will leave it where it is. I’m not even sure my hosting site offers email yet, anyway. And I don’t know anything about Plesk either, so I’ll see if setting them back to proxy helps or not.

I tried your solution and my hosting site accepted the DNS settings right away - awesome!

Again, thank you!

I’m still getting a “Website Under Construction” page sometimes when I try to get to the site. Not all the time, though. Is that just a matter of time before that corrects itself?


I have no idea what you are expecting to see there. The only thing I saw prior to this Website Under Construction page was an XML raw HTML message served as plaintext indicating that Plesk had not created a site at that name yet. You might need to check with Pub Site.

UPDATE: It was not XML, it was unrendered HTML

I expected to see the home page of my site. Which I do sometimes - but if I give the link to someone via a message, the under construction page shows in the preview. I have talked to pubsite, and hope they have an answer.

1 Like

Since I have only see the under construction page, I still don’t know what you expect to see. From where I am, that is the homepage of your site. :wink:

Hang in there and see what Pub Site comes back to you with. There may be some action required on your part to publish your site in place of the under construction page.

Ah, okay. I see what you mean. I CAN see my actual homepage, which looks like this.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.