Problems changing the server

I have changed the server where my website is hosted, then I entered the cloudflare to change the settings. I tryed to change the IP address in cloudflare, but it doesn’t worked.

Then I deleted the CNAME and A settings and entered again, the A setting I entered OK, but it wasn’t possible to add a CNAME (error: DNS Validation Error (Code: 1004) Content for CNAME record is invalid.).

Now, the DNS doesn’t resolve and the website only access by IP. How can I configure the proper way

I much prefer to use IP addresses only (“A” records).

Since that “A” record worked, make an “A” record just like the first one, but for that other one instead of a CNAME.


@sdayman thanks for the support!!

I have dona the “A” record!! But it doesn’t worked, instead appeared the DNS_PROBE_FINISHED_NXDOMAIN error, neither proxy nor only DNS are working. I checked the IP address and it’s correct.

The domain could not be found or does not exist

Have you checked to see if your nameservers are propagated correctly!

If I may ask, what is the domain?

If you need further assistance, please post a screenshot of your DNS records page here. It’s ok to black out IP addresses. And please let us know which two name servers Cloudflare shows at the bottom of that DNS page.

@AppleSlayer , sure, the domain is

@sdayman , follows the DNS records:


thanks again guys!

No HTTPS support


Have you changed your nameservers within the last 72 hours? If so, the changes may not yet be fully propagated and that might be why this issue is occuring!

Also, do you have “Full (Strict)” set in the overview tab of your SSL/TLS settings?

You have WordPress configured to use the IP address. Check your wp-admin Settings → General for the URL and make sure it’s

You can also set it in wp-config.php:

@sdayman problem solved, I forgot to alter that setting, my bad

@AppleSlayer I turned on aways use HTTPS option, and the result have changed to:

about the time, the DNS settings were altered yesterday, are they altered correctly to be in place in 72 hours? do I need to alter any other setting?

1 Like

I see you are getting a 521 error, below are troubleshooting steps for the error

Error 521: web server is down

Error 521 occurs when the origin web server refuses connections from Cloudflare. Security solutions at your origin may block legitimate connections from certain Cloudflare IP addresses.

The two most common causes of 521 errors are:

  • Offlined origin web server application
  • Blocked Cloudflare requests


Contact your site administrator or hosting provider to eliminate these common causes:

  • Ensure your origin web server is responsive
  • Review origin web server error logs to identify web server application crashes or outages.
  • Confirm Cloudflare IP addresses are not blocked or rate limited
  • Allow all Cloudflare IP ranges in your origin web server’s firewall or other security software
  • Confirm that — if you have your SSL/TLS mode set to Full or Full (Strict ) — you have installed a Cloudflare Origin Certificate
  • Find additional troubleshooting information on the Cloudflare Community.

Also, I don’t get the error for that URL (all I see is this)