Problema em carregar alguns arquivo e imagens

Bom dia! Estou com problema em alguns carregamentos de alguns arquivo e imagens no momento que entro em algumas páginas. Estou com este problema em 2 clientes, ambos estão hospedados na Locaweb. Entrei em contato com eles, e me GARANTIRAM que não há nenhum bloqueio por parte deles.
Mas se acessar o link:
https://www.joaresmachado.com.br/upload/site_categoria/6_listagem.jpg (não abre)
https://www.joaresmachado.com.br/upload/site_categoria/6_listagem.jpg?v=1 (abre)

Eu imagino que possa ser porque o sem “?v=1” foi requisitado junto com vários outros arquivos e neste momento demorou um pouco a requisição ou houve um bloqueio na Locaweb (eles me passaram que não há este bloqueio). Mas se fizer a requisição isoladamente com o “?v=1”, neste caso, funciona.
Imagino que quando é feita a requisição e retorna erro, este erro fica em cache, ou algo assim.

O outro projeto é neste link: https://www.espacodatorre.com.br/galeria
Sempre tem alguma miniatura que não carrega, retornando o erro 502 ou 522. Ex:
https://www.espacodatorre.com.br/upload/site_galeria/51_p.jpg
https://www.espacodatorre.com.br/upload/site_galeria/56_p.jpg

Já tentei desabilitar o SSL, mas ocorre o mesmo problema.

Por favor, podem me ajudar?

abs

Boa tarde Joares tudo bem? Estou enfrentando o mesmo problema. Ora carregam imagens e ora carregam erros 502 no Wordpress x Cloudflare x Locaweb. Será que e pau na Locaweb?

Obrigado.

Também estou com o mesmo problema e uso revenda Cpanel na Locaweb.

Meus sites não carregam algumas imagens as vezes dando ERR_TOO_MANY_REDIRECTS, outras horas carregam. Sites não carregando CSS e JS, quebrando todo o site, quando vou olhar no Console do navegador alguns links após o domínio é incluído códigos, tipo: http://www.meudominio.com.br/wp-content/themes/nomedotema/style.css aparece assim http://www.meudominio.com.br/oMYPO/wp-content/themes/nomedotema/style.css isso ocorre também nos links das postagem gerando Página não localizada.

Sites demorando a responder e dando ERR_CONNECTION_TIMED_OUT. Paginas com SSL dando Erro 525.

Na Locaweb eles me passaram que vários clientes já informaram esses problemas, e todos em comum usam o Cloudflare, mas alegam que o problema não é na hospedagem deles. E realmente quando desativo o Cloudflare os problemas somem.

Se alguém tiver uma solução, agradeço.

Alguém conseguiu resolver o problema? Estou tendo problema com timeout também.

Oi @valtlfelipe,

Que mensagem de erro vc está recebendo?

Com o Cloudflare ativado algumas requisições demoram bastante para responder, e estou recebendo erros HTTP 522 (Connection timed out). O site usa SSL.

Geralmente o erro 522 acontece quando as solicitações do Cloudflare para o servidor na origem são bloqueadas. Dá uma olhada nas dicas da Comunidade nesse link sobre como resolver: Community Tip (Em inglês, mas vc pode jogar o URL no https://translate.google.com que sai traduzido.

@floripare então, obrigado pelas informações. Mas a questão é que é uma simples hospedagem da locaweb, e a princípio não está bloqueando nada. Os colegas acima relataram a mesma situação.

Entendo. Mas o último dos relatos acima foi de agosto de 2018, e eles não necessariamente indicam que havia um problema do Cloudflare na época. Sem falar que eles mencionam erros diferentes do seu, um deles relativo a SSL, e outros. Cada código 5xx significa um problema diferente.

No caso específico do 522, significa que alguma coisa está bloqueando o Cloudflare na origem. Pode ser uma regra no .htaccess ou no httpconf, pode ser um “rate limiting”, que é quando a um IP só é permitido um certo números de solicitações por segundo etc.

O que vc deve fazer é ver se tem como eles fazerem o whitelist dos IPs do Cloudflare, para evitar que sejam bloqueados pelo firewall ou qualquer outro mecanismo deles.

Caso não tenha sucesso, esse outro documento menciona algumas medidas que vc pode tomar antes de abrir um ticket no suporte do Cloudflare.