Problem with website migration


#1

Hello,
First of all, I am not a developer, so please bear with me!

I have a live version and a staging version (dev). My website is e-commerce, built with wordpress and woocommerce. My theme is storefront. My hosting provider is gandi.net. For backup and migration, I use duplicator pro.

So, yesterday I was getting a 500 (internal server error) when trying to upload a post to the blog. Trying to locate the problem, I broke my dev and since then I am trying to build it again.

Problem 1) While running the installer of duplicator, I was getting a non-secure connection warning, which was not letting me pass throught it. This issue was the same in all browsers (firefox is throwing a warning and doesn’t allow me to proceed, Opera and Edge keep refreshing, and the green lock left to the url keeps altering from secure to non-secure) and other pc’s as well. I can’t locate the source of this problem, but I managed to bypass it by adding a firefox plugin (smart https). The warning is still there, but it lets me proceed.

Problem 2) After the, duplicator begins extraction, but after a while I get a 524 timeout error. I had faced the same issue a couple of times recently, but after repeating the procedure a few times, it was ok. Now, the 524 error is the result of every extraction attempt with duplicator.

So, I sent a ticket to hosting provider (Gandi) and they replied “your instance is undersized for the code and traffic associated with the websites.” (Current plan is Small, with 2 php workers). The max_execution_time of PHP scripts is 180 seconds.

I upgrated my hosting plan to medium, doubling php workers. However, I still get this 524 error. So, I asked Gandi again and they replied “The error is being reported by Cloudflare. They might have a lower timeout value than the max_execution_time of PHP. I suggest temporarily disabling Cloudflare filtering for this website (click on the Orange cloud next to the DNS record at Cloudflare), and then try running the installer again.”

So, I changed the CNAME dev from orange to grey and tried again.

In my first attempt, I got the following error: An error occurred during a connection to dev.meliory.gr. SSL peer has no certificate for the requested DNS name. Error code: SSL_ERROR_UNRECOGNIZED_NAME_ALERT

I tried again, the installer run normally and finally got again this 524 error.

Please assist, I am totally lost!

I appologize for the long post and the exhausting details, but I am not even sure which problem is relevant and which is irrelevant!

Thanks in advance!


#2

Regarding #2, Error 524 is being passed through Cloudflare, it is not because of CloudFlare. In nearly every case in the past, this error is caused by the host ISP firewall blocking traffic to CloudFlare’s IPs. I suggest you update your ticket with Gandi, asking them to check for that.


#3

Hi Jules,

As an update, I paused website from cloudlare and everything went through perfectly fine. No security connection warnings, no 524 error. I guess that this is not a proper procedure, just a bypass until I locate and resolve the problem.

I understand what you say and I will follow up with gandi, regarding the blocked cloudflare’s IP. I will let you know their reply.

Regarding the insecure connection warning, could it be caused by the same issue of blocked IP, or I should check in another direction, such as my cloudflare’s settings or the ssl?

Thank you


#4

When you Pause a website, traffic bypasses cloudflare. If traffic is moving fine, it means CF’s IPs are being blocked.

As far as the insecure warning… we’d have to see it. It could be because of the block.


#5

Hi Jules,

Thank you very much for your reply.

Today I tested again and this time I got security connection warning and 524 error, even with CF at pause. Unfortunately, I get contradicting results under the same conditions (theoretically). So, I will keep looking at it. I will keep you updated and probably, if I reach a dead end, I will send you credentials to see all the setup.

In the meantime, Gandi replied to my last ticket that "it looks like Cloudflare only waits for 100 seconds before issuing a timeout error, so if your installer takes longer than that to run, you’ll receive the 524 error.

Reference: https://support.cloudflare.com/hc/en-us/articles/200171926-Error-524-A-timeout-occurred

The max_execution_time for PHP on Simple Hosting is 180 seconds - I suggest contacting Cloudflare support and asking if you can increase the timeout value to 180 seconds."

I understand that timeout for CF is set to 240 sec and I let them know. However, they didn’t answer my question, if they block CF’s IPs.

I am thinking of moving to another host and I look into siteground, which I guess cooperates perfectly with CF. However, I want first to make sure that such procedure will eliminate these issues, before making any final decisions.

Thanks & Regards


#6

Hi,

I am having the same issue and also noticed that the Cloudflare support page says “Our edge will typically wait for a HTTP response from your server for 100 seconds.” I have an ecommerce site with thousands of products and a lot of the jobs we do take several minutes to process so 100s is way to low for us to be able process our jobs. Is there a way we can increase this timeout setting?

Thanks


#7

Hi tejjohal,

I have not located the source of the problem yet. For the moment, I temporarily pause CF and I bypass it. If I find a solution, I will let you know.


#8

I found out the issue on a lucky Guess. I wasn’t able to download my files from Duplicator. I turned off the Railgun feature temporarily and it worked! It’s under speed/railgun in the main cloudflare control pannel. I got the idea from this article. https://support.cloudflare.com/hc/en-us/articles/200171926-Error-524-A-timeout-occurred