Problem with vhost (SSL handshake failed)

hello ,
i have problem with vhosts-ssl.conf ,

when i set settings like this :
<VirtualHost 192.168.2.100:443>
ServerName xxxxx. com
ServerAlias www.xxxxx. com
ServerAdmin [email protected]
DocumentRoot /home/xxxxxx/public_html
UseCanonicalName Off
ScriptAlias /cgi-bin/ /home/xxxxxx/public_html/cgi-bin/

i got problem Error 525: SSL handshake failed

but when i set main ip address everything work good ,

<VirtualHost 178.xxx.xxx.xx:443>
	ServerName xxxxx. com
	ServerAlias www.xxxxx. com
	ServerAdmin [email protected] com
	DocumentRoot /home/xxxxxx/public_html
	UseCanonicalName Off
	ScriptAlias /cgi-bin/ /home/xxxxxx/public_html/cgi-bin/

so pls help me out how i fix that , how i use vhosts ip 192.168.2.100 without any problem

thank you .

Try setting the opening tag to
<VirtualHost *:443>
This will make it respond to both the IP and that internal IP.

after i apply <VirtualHost *:443>
all website no workings without ssl , and all directory domains : /home/xxxxxx/public_html

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.