Problem with updating DNS records


I am new to all this tech stuff and having an issue authenticating my site for a new email provider.

I have to update CNAME records and TXT. However I am getting an error saying: “SenderID/SPF has more than one record. Remove all others and leave only one” for the TXT record but I don’t know which one to remove in case it affects other things that are set up?

Clearly I have done something wrong and i have a big email going out tomorrow so need to fix. Any advice or help please. thanks

Welcome to the Cloudflare Community. :logodrop:

If you share your domain name, Community members can better advise you.

thank you, it’s njingacycling com

If you look at your SPF records, you will see that the larger contains the value in the smaller. The smaller can be deleted.

v=spf1 ~all
v=spf1 ~all
1 Like

thank you so much but I dont understand what that means, where is the larger v the smaller? sorry this is all new to me.

The smaller record is the one with less characters:

v=spf1 ~all

You should delete that record.

1 Like

thanks- I just tried that and I got an error saying: authentication error, CODE 10000

Anyone able to help please?

Are you trying to make these changes in the dashboard or in some other app?

Is the domain in your own account or were you invited to another person’s account?

You could try using a private browser window and see if that helps.

in the cloudflare website. And domain in my account. Let me try private browser now. thank you

thank you so much- that worked in private browser. Now just the CNAME issue. I still get this error: DomainKeys/DKIM records were not found. Make sure you have added them.

Have you added them?

You have not shared any information on what CNAME record you were asked to add (name/content), so it is impossible to help you with that.

1 Like

Almost impossible. With the way Cloudflare synthesizes A and AAAA records for proxied hostnames, it is always worth recommending that verification CNAMEs are set to :grey: DNS Only.

1 Like

So sorry I thought I had written that in original request. Its ```

I currently have it proxied. should I just turn that off?


Yes. Proxied CNAMEs publish A and AAAA records. No CNAME is published. This results in CNAME lookups returning empty. If you need to receive a CNAME as an answer, you must use :grey: DNS Only.

1 Like

Amazing thank you so much. That has done the trick! so by that I assume ALL my CNAME records should be DNS only?


Names that you want to route through the Cloudflare proxy need to stay :orange:.

ok thank you so much. really appreciate your help

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.