Problem with Universal SSL

Good afternoon! I have a problem.

My site only works on the HTTP protocol. I can’t use the HTTPS protocol because all the links inside the site are HTTP.
Cloudflare’s PROXY service is enabled in DNS. If I disable PROXY, automatically redirects to HTTP when you visit via HTTPS in my site .htaccess settings.

The problem is that my site is not redirecting from HTTPS to HTTP when the PROXY is turned on. I previously solved this problem by disabling Universal SSL.

I recently moved my site to another server because my old server was down. I have many years of experience with the site.

Currently you will see this problem if you visit my site via HTTPS:

UNIVERSAL SSL is currently disabled. If I enable it endless http>https>http>https>http>https… redirect happens.

I can’t solve this problem. Can you help? Thank you in advance!
I apologize for the spelling mistakes. I used a translator.

Perhaps, you do have a valid SSL certificate.

Can you try one thing?

Switch to Full Strict SSL mode & Disable the Automatic HTTPS in Cloudflare. This might help.

You would likely need to employ that same mechanism to use HTTP in modern web browsers.

Is there a reason not to use HTTPS at your origin? The links in your site can easily be updated to work with HTTPS by removing the scheme from them.

Use // instead of

1 Like

I tried it. But it didn’t help. There is no change. What other methods are there? Thank you in advance!

Hello bro! I can’t use https because the external links on my site are not https. What other methods are there? Thank you in advance!

You can easily redirect incoming HTTP requests to HTTPS using Cloudflare.

Cloudflare provides multiple options.

The one click approach:

I prefer to use custom redirects:

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.