Problem with the SSL installation

Hello, dear support, can you help me?

I intstall your free SSL in my domain. My hosting provider is GPDhost. I install SSL in cpanel. GPDhost support said that SSL was installed, but my site doesn’t work, and my GPDhost support said that the problem that the sites doesn’t work because of Cloudflare.
Please can you check and say what’s the problem and help me to fix the problem.

Thank you in advance.

Hi @babajanyan, you’ve reached the Cloudflare Community and we will do our best to help you out. To start, can you share the name of the domain you’re asking about, any errors you’re seeing, and/or screen captures of what you’re seeing?

(In case we cannot assist, to contact Cloudflare Customer Support, login & go to https://dash.cloudflare.com/?account=support and select get more help. Please give Support the complete details and link to your Community post.

(Here’s a bit of background on Cloudflare Support for reference: https://support.cloudflare.com/hc/en-us/articles/200172476-How-do-I-report-a-bug-to-Cloudflare-)

1 Like

The details of our problems are: sites don’t open. This is my page (www.lavjen.com). My hosting support said that I have caching and send me this bug in screenshoot

Two Three issues here that I can see clearly.

  1. You have no record for www.lavjen.com, so it won’t work. usually it’s a CNAME to your root. This will help.

The error “No A, AAAA or CNAME record found” or “ERR_NAME_NOT_RESOLVED” means that you don’t have required entries in your DNS zone file at Cloudflare for the site to resolve properly. When you add a zone to Cloudflare, we run a DNS scan that goes through a dictionary of the most common DNS names and it queries the current name servers. In that process, we import most existing DNS records. If the DNS records are unique or the domain is newly registered, our system may not detect the records and you’ll need to manually add them on the DNS tab of the Cloudflare Dashboard.

Review the suggestions in this Community Tip and let us know if you continue to see issues after trying Quick Fix Ideas, we’re happy to help further.

If you are unsure how to add the DNS records you need, there is a community tutorial on this.

  1. The error you see is not cause by Cloudflare’s SSL, but by your origin, so GPDhost. How did you install SSL? What configuration do you have in the SSL/TLS app of Cloudflare’s Dashboard? this should also help.

A 522 error typically happens when Cloudflare requests to the origin (your webserver) get blocked. Review the suggestions in this Community Tip for troubleshooting ideas.

  1. The error shows up in HTTP as well, you need to enable the redirect to HTTPS in the SSL/TLS app. You should also consider doing a Page Rule force all traffic to www.lavjen.com or lavjen.com to not have duplicate URL for the same content. These help with the issue 1 above.

If your domain works when you visit example.com, but not when you just visit www.example.com, you may want to redirect www to your root domain using a page rule. You can follow this community tutorial on how to do this.

If your domain works when you visit www.example.com, but not when you just visit example.com, you may want to redirect your root domain to www using a page rule. You can follow this community tutorial on how to do this.

1 Like

About 1 issue with DNS, I dont understand everything, but my DNS records in domain’s page here are

About with the other problems I dont know how to solve.

What about second problem with the SSL install, I installed with the all rules: firstly I create SSL Certificate ,
then I copied the certificate, key and Cloudflare’s original certificate,
I did a setting: certificate’s time, function, and choose flexible , activated the subdomains.
Next, I installed in cpanel: SSL Certificate, key and Cloudflare’s original certificate (RS).
I dont know if it need to do more for installation. Maybe its needed to install any file in the root folder?

About third one, in SSL/TLS app I setting HTTPS, I dont know why there is a problem.
Our ssite doesnnt oopen not in www.lavjen.com nor in lavjen.com. If someone can help me I cann give me my details.

  1. The issue is not related to the name servers, but to the actual DNS records in the Cloudflare Dashboard.

  2. The certificate, from what you tell me seems installed correctly. There shouldn’t be other things. You could try pausing Coudflare (it will expose your origin, but it would be for a little bit just for me to check some things).

  3. You need to enable Always Use HTTPS and possibly Automatic HTTPS Rewrites.


Again, as above. The www version is due to the fact that there isn’t a DNS record (duplicate the record for www or add a CNAME, as mentioned above), both have issues with the origin not accepting things. It’s not Cloudflare.

PS: reply to my posts, not the thread, I don’t get notifications otherwise.

1 Like

okay, and how I can fix all this. step bay step can you tall.

  1. Here are instructions to fix the ‘www’ error @matteo mentioned:
    Redirect www.example.com to example.com

  2. In Cloudflare DNS, set lavjen.com to :grey: to make sure your site is working. You will have to wait 5 minutes for DNS to update before you can test your website.

  3. Those HTTPS settings are in the Crypto section of the Cloudflare Dashboard.

1 Like


please see all and tall my, now in what my problem ?

That’s 2 out of 3. You need to set lavjen.com to :grey: in order to fix your server.

The missing MX record is whatever your host tells you it should be.

how I can install it ? and where I should install ? and what is MX?

Can you tell my in plain language. I go to DNS tab. Where, in which section I should write this. And in my example, in my domain lavjen.com. what I should write? what I should writ places of it ( <a class=“lightbox” href")

Please click the link and read the tutorial.

1 Like

Wait a moment, don’t enable HSTS! Wait until you are sure, especially with a max-age of 5 months.

You will break your website and all subdomains for a long while.

1 Like

thank you very match. I do it all.

but site again don’t working. I must wait or problem in another?

this my site page

$ curl -I https://lavjen.com
HTTP/2 522 
date: Sat, 20 Jul 2019 01:05:31 GMT
content-type: text/html; charset=UTF-8
set-cookie: __cfduid=df3d83af9ed48a0f4dd54e8bdfbc40dd01563584700; expires=Sun, 19-Jul-20 01:05:00 GMT; path=/; domain=.lavjen.com; HttpOnly; Secure
strict-transport-security: max-age=12960000; includeSubDomains; preload
x-content-type-options: nosniff
expect-ct: max-age=604800, report-uri="https://report-uri.Cloudflare.com/cdn-cgi/beacon/expect-ct"
set-cookie: cf_use_ob=0; path=/; expires=Sat, 20-Jul-19 01:06:01 GMT
expires: Thu, 01 Jan 1970 00:00:01 GMT
cache-control: no-store, no-cache, must-revalidate, post-check=0, pre-check=0
pragma: no-cache
server: Cloudflare
cf-ray: 4f91063a7a4ad610-MXP

You haven’t disabled HSTS. Do that, now. I mean right now. Read the warnings in the pop-up to enable/disable it. They explain the problems that can arise.


We have listed all the steps to fix the issues, multiple times. Follow them by reading all the guides linked by @sdayman and myself. Until you follow them you won’t fix the issue and there isn’t anything more we can do.

2 Likes

did you mean it ?

No. Read again.

1 Like