Problem with the DNS Cloudflare Plugin for Certbot

plugin
#1

Hello,

I have a problem with the DNS-Cloudflare Plugin for Certbot to automatically renew my certificates. The following command worked fine for me:

sudo certbot certonly --dns-cloudflare --dns-cloudflare-credentials /path/to/certbot-cloudflare.ini --server https://acme-v02.api.letsencrypt.org/directory -d *.my-domain.com -n --force-renew

But since yesterday I get the following error message:

“Plugins selected: Authenticator dns-cloudflare, Installer None
Missing command line flag or config entry for this setting:
Please choose an account
Choices: [‘my-domain.com@2018-05-17T08:16:11Z (fffd)’, ‘my-domain.com@2016-04-16T19:45:34Z (5481)’]”

Does anyone know, which command line flag or config entry I have to add?

Many thanks in advance!!

#2

Looks like these functions are the culprit. Short answer is that this isn’t something regarding Cloudflare accounts.


I’ve been looking through the source code and i’ve been unable to find where the account storage is located, but the interface looks like it’s AccountFileStorage.

1 Like
#3

Thank you very much for your fast and very helpful reply.

I didn’t know about Certbot accounts but after a little research I found out that there were two accounts under /etc/letsencrypt/accounts/acme-v02.api.letsencrypt.org/directory/ and I had two add the command line argument ‘–account’ together with the name of the directory.

Now it works fine.
Again, thank you!

1 Like
closed #4

This topic was automatically closed after 30 days. New replies are no longer allowed.