Problem with SSL :S

Hello,

I have problem with my WebSite when i set SSL Full - Encrypts end-to-end, using a self signed certificate on the server

My website go Offline :slight_smile: Here is the screenshot :slight_smile:

Regarding your issue about 521 error:

Have you had an HTTPS connection at your host/origin before adding your domain to Cloudflare?
Moreover, to use Full SSL, you would need to have an SSL certificate at your host/origin.

Kindly, could you please try to follow the steps from the article below to solve your problem:

This makes me think your server isn’t listening on Port 443. If you :grey: DNS Only that record,then wait five minutes, can you reach your site with HTTPS? You should at least get a certificate error in your browser.

1 Like

What’s the website your getting this error on? Also is “always online” mode on because if so it should still load an un-cached copy of your website. Also, I’m sorry to hear your getting the 521 error, check to see if cloudflare IP’S are allowed to bypass or allow in your firewall settings. A list of cloudflare IP’s is available at IP Ranges | Cloudflare Also the cause of the 521 error? Error 521 occurs when the origin web server refuses connections from Cloudflare. Security solutions at your origin may block legitimate connections from certain cloudflare IP ranges
The two most common causes of 521 errors are:

  • Offlined origin web server application
  • Blocked Cloudflare requests

I hope to hear back from you soon!

Who is your hosting provider?
With Bluehost and Godaddy you will have this issue.