Problem with SRV Record

I setted up a A Record for my server minecraft, this record points to my server IP (TLS=auto) and then i setted up a SRV Record (TTL=auto), because i need the connection go on the port 25577. When I try to ping the DNS with the cmd (ping it return a “Unknown Host” Error.
I tried to change the port of the SRV record from 25577 to 25565 (default port of minecraft servers) and it worked instantly.

If the record is proxied :orange:, I would suggest looking into below article for supported and compatible ports list:

1 Like

Hi @enderf5027,

SRV records tell specific services, such as Minecraft, to use another host/port when connecting. Ping requests do not honor SRV records - they use the ICMP protocol which does not have a concept of ports (unlike TCP/UDP).

So I’m unsure why an SRV record would prevent pings from succeeding - are you sure nothing else changed?


I already reproduced the steps in the tutorial. Im not using Cloudfare Proxy.
My settings:

I tried to connect with Minecraft too but it didnt found the host (same as Windows Cmd). I asked to a friend to connect and ping the domain and he have the same problem (im using DNS Server and he is using

Please follow the guide suggested by fritexvz :slightly_smiling_face:

From your screenshot A type is :grey: too.
Meaning, goes straight to your origin.
Does exist and can it be resolved at the origin actually and listening over the wanted port (is it open too?), if so?

When i do NSLookup this appears:
Windows 11:
Ubuntu 21.04:

With if I try to check the port, it says it’s open.

SRV records work for specific TCP/UDP services only. As I said earlier ping uses ICMP so doesn’t respect SRV records, only A/AAAA records. There is no A/AAAA record for so pings will fail.

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.