Problem with my ssl can't connect is it cloudflare? (handshake failure)

I’ve tried multiple things, and i keep getting a handshake failure, my https works but all of a sudden one of the web services i use stopped working, and the error being handshake failure, see below: ssl is all setup and working but something is going wrong along the way,

openssl s_client -connect hearthijab.com:443
CONNECTED(00000003)
140475921536680:error:14077410:SSL routines:SSL23_GET_SERVER_HELLO:sslv3 alert handshake failu re:s23_clnt.c:802:

no peer certificate available

No client certificate CA names sent

SSL handshake has read 7 bytes and written 311 bytes

New, (NONE), Cipher is (NONE)
Secure Renegotiation IS NOT supported
Compression: NONE
Expansion: NONE
No ALPN negotiated
SSL-Session:
Protocol : TLSv1
Cipher : 0000
Session-ID:
Session-ID-ctx:
Master-Key:
Key-Arg : None
PSK identity: None
PSK identity hint: None
SRP username: None
Start Time: 1573475034
Timeout : 300 (sec)
Verify return code: 0 (ok)

I’ve paused cloudflare and now it works,

i want cloudflare to be enabled at all times, so any idea where i am going wrong?

It sounds like your Cloudflare TLS certificate hasn’t been generated yet. Sometimes it takes a little while. Sometimes it just gets stuck.

Here’s a support article on the subject. Scroll way down to the “Your cert is not active” section.