Problem with multiple non-www to www to https redirects

Hello,
I am getting the double redirect, site_com >> www_site_com >> https://www_site_com
I am trying to skip the extra step and point everything with one redirection to the https with the www. So everything goes to the https://www_site_com in one step.

So far I have the page rule:
www.site.com/* with “Forwarding URL - 301 Permanent Redirect” option and the value of https://www.site.com/$1

I have Always Use HTTPS ON
I have HSTS activated (which I read could be an issue but I can turn that off and the problem persists).

For my Cloudflare DNS I have three A name entries:

  •              to IP address
    

site.com to IP address
www to IP address

No other A or C name entries.

I suspect the issue is with my DNS setup , any help would be appreciated.

Thank you,
George

You don’t need that page rule. Just make sure “Always use HTTPS” is enabled and you should be good. You’d only need the page rule from the naked domain to “www” in your case.

2 Likes

I tried the page rule adjustment but now I see naked > https naked > http www.
Still two steps instead of one. Any other ideas?
Thank you.

Could you post a screenshot of your current list of page rules?

Just tested it. The page rule mentioned earlier did work as expected

site.com/* -> https://www.site.com/$1

Double check your settings and the page rule order, but also post the screenshot.

Sandro, I am still getting the double redirect according to pingdom.
Any help would be appreciated.
Thank you ,
George

You are redirecting to HTTP in your page rule.

Plus, your DNS records are not proxied, so the page rule will never fire either.

Issue fixed, thank you for your guidance.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.