Problem with https://search.google.com/test/rich-results

In terms of this and Ajax and JS webpages:

You might need to implement Dynamic Rendering:

Or give it a try with prerender.io ?:
https://prerender.io/

If your main webpage content is being rendered via JavaScript, I am not sure and not familiar how does Cloudflare affect this by blocking it? :thinking:

I have to admit, this is something new to me and I have less experience in this case.

1 Like

Hi Fritex

Thank for your help and the links.

The problem now is more on why when i use Cloudflare, google didnt manage to load all javascript files. Google can load all of the javascript when i disable Cloudflare.

I have tried to disable as much as possible configuration on Cloudflare but it didn’t help.

Let me know if you need any more info to explore about this issue. I hate to stop using cloudflare because of this…

1 Like

Does that JS files generate HTML content, or rather React does?

Can you write the HTML content which is needed to be in the <head>, like meta tags and in terms of JSON-LD schema, for the proper and correct SEO while other can be loaded later, if so?
As far as I can see the HTML is loaded correctly, except what the JS files are doing or should do with the content, but Googlebot cannot disaply that :face_with_diagonal_mouth:

That is a bit strange behaviour :smiley:

1 Like

I would actually like to close that down since we are running in circles again and again…

What we need to debug this are still (which you have not provided) live tests on your domain, where it happens. 4 of them will be required.

PLAN Proxy URL
Free Plan :orange: https://test.hungryfoody.com/test/test.html
Free Plan :grey: Not provided yet
Pro plan :orange: Not provided yet
Pro plan :grey: Not provided yet



:orange: and :grey: should be on different subdomains like

:orange: : https://test.hungryfoody.com
:grey: : https://test2.hungryfoody.com

Please reply with all that info altogether, so we don’t have to Ping-Pong here back and forth. This step is required for further investigation, since the tool you use (Googles Crawler) does not let us debug/analyse this, nor does it throw a meaningful error.

Thanks.

Hi M4rt1n

can we use this?

pro plan cloudflare proxy disable
https://search.google.com/test/rich-results/result?id=nvFpzVmjRNN8rytj6UNlvg

pro plan cloudflare proxy enable
https://search.google.com/test/rich-results/result?id=qFzAz5uHlh-gDmeTnOu8nw

I cant give you the free plan one i believe that one is enough proof for the problem. anyway we only interested on pro plan.

Thats enough, yes. I can see and reproduce the issue with these two links now.
Please open a support ticket and provide us with the ticket id here.

Hi M4rt1n

Thank you for your patient.

Can we use this ticket id 2348028?

Thanks

I honestly don’t know. But if it is a ticked, you just now created for this problem, then yes.

Hi M4rt1n

I created that ticket before i post in here, it is about same issue.

Please me know if anything i can do to find the answer

Thanks

You don’t need anything. I escalated it with the Cloudflare devs. They will respond to you as soon as they do have any additional info, or instructions.

2 Likes

I responded on the ticket…

Hi Jochen

Thank you for your reply, i have replied back also. and explain more about the problem, i use google tools not to check for the rich snippet but for the resources that is not success loaded.

Let me know if you have any more question

Thanks

I havent get any good news from the ticket.

Anyone can help on this?

Thanks

Hi Jochen,

Can you help to see on this issue? it has been so long

Let me know if you have something that i can help to expedite this

Thanks

Hi @jochen

Can you please help to reply my ticket regarding this issue?

No ticket 2348028

Thanks

You can use @ MoreHelp because it’s so long
Waiting

1 Like

@M4rt1n

Do you know what is the configuration on Cloudflare that can change the request tree from

to

I disabled almost of the configuration, now it works ok but i dont know which one impacted the tree like that

Please open a new thread for a new topic/problem so we have everything here in order and good structured for future visitors.

Was “Mirage” also activated before? And are these tests messured on mobile or desktop?

Thanks for your answer @M4rt1n , actually my question still related with the main problem where by when use Cloudflare googlebot wont load all the resources. It make the client rendering side suffer.

I found out other things that googlebot timeout is 10 secs, means google will ignore the other resources if the page loaded more than 10 secs.

when i use Cloudflare, googlebot load each assets like 1 javascript 1 seconds. But when i didnt use Cloudflare it load super fast

can you see below video as comparation? and do you think it is expected behavior?

Video for resources is loaded when disable cloudflare

Video for resources is not loaded when use cloudflare

Thanks

@user18735 Thanks for feedback.

In the 2nd video, where resources aren’t loaded when Cloudflare proxy :orange: is enabled, I can see the Cloudflare IP :thinking:

Which got my attention and I am assuming your web server is not returning real visitor IP when you are using Cloudflare.

Therefore, kindly I’d suggest you using below article to scroll down a bit to find your web server type and implement the solution as follows:

UPDATE 1:
Consider re-checking if Cloudflare IPs are allowed to connect/pass to the origin host/server:

Nevertheless, Cloudflare IP addresses list can be found here:

UPDATE 2:
If issue persists try disabling the RocketLoader and AutoMinify - JS too → test.worldroamer.com/test/test.html (as already suggested in few posts from above).

UPDATE 3:
test2 is over HTTP 1/1 from your origin host (Nginx - which can be tuned-up!), while test over HTTP/2 or even HTTP/3 if enabled at Cloudflare.

Seems to me like there is no HTTP to HTTPS redirection configured? :thinking:

2 Likes