Problem with https://search.google.com/test/rich-results

I have problem on https://search.google.com/test/rich-results

When the files loaded with cloudflare it will just showing error

my html is like this

<html lang="en"><head>
        <title>test only</title>
    </head>     
    <body>
        <div id="a"></div>  
        <script src="js/a1.js"></script>        
        <script src="js/a2.js"></script>        
        <script src="js/a3.js"></script>        
        <script src="js/a4.js"></script>        
        <script src="js/a5.js"></script>        
        <script src="js/a6.js"></script>        
        <script src="js/a7.js"></script>        
        <script src="js/a8.js"></script>        
        <script src="js/a9.js"></script>        
        <script src="js/a10.js"></script>        
        <script src="js/a11.js"></script>        
        <script src="js/a12.js"></script>        
        <script src="js/a13.js"></script>        
        <script src="js/a14.js"></script>        
        <script src="js/a15.js"></script>        
        <script src="js/a16.js"></script>        
        <script src="js/a17.js"></script>        
        <script src="js/a18.js"></script>        
        <script src="js/a19.js"></script>        
        <script src="js/a20.js"></script>
    </body></html>

on js/a1.js is simply like this

var a1= 'a1'; document.getElementById('a').innerHTML += a1 + '<br>'

for a2.js will be like this

var a2= 'a2'; document.getElementById('a').innerHTML += a2 + '<br>'

and so on

this is what i get

You can try on your server with file download here

May I ask does the issue resolve when you temporary enable the “Pause Cloudflare for this site” option from the Overview tab of Cloudflare dashboard for your domain name?

Furthermore, have you already tried to disable the Rocket Loader option or maybe you enabled the Auto Minify - JS option?

I remember I got these reports on almost every page, but it’s related to 3rd-party scripts like Google AdSense, or some other ads, etc.

Without looking and downloading, may I ask what is your final goal and what you are trying to achieve?
Cannot you combine all of them into the one JS file or rather using head and script HTML tag?

Is the webpage fetched and the result “success”, or rather these are just warnings as Googlebot might not fetch those JS resources?

1 Like

HI Fritex

Thank you for your response.

Yes when disable or pause the cloudflare proxy it works properly and can load all the content properly.

I have tried to disable almost all the feature for cloudflare with no luck

I face problem on my real website, I cut the problem to smaller pieces by creating prototype like that. By this way is easier to explain to this community and omit all the javascript blocking things.

The impact for this is google didnt cache my page properly, thus my traffic is dropping.

for now i cant combine the javascript, but the real problem is not combining, even i can combine my javascript, the other static files e.g css / font / images also will have same problem. I feel when use cloudflare if the pages load many external the problem will comes. when i say many is more than 10. i use same script if i only load 10 scripts, it works properly.

My final goal is to let google to understand my website without me changing many things.

Any idea beside disable the cloudflare proxy?

Prior to this i have contact cloudflare, it didnt solve for almost 3 weeks, so i decided to use this forum.

Hi Fritex

Disable the proxy it works for me.

I disable almost of the feature of cloudflare with no luck

The script is just prototype to see the problem in easier way. My website us using React and it depend on javascript, if there is javascript is not loaded, google wont be able understand the website. So my goal is to let google be able to render my page.

Even if i can combine the javascript, it wont solve the problem, because it will show error for other files e.g css / images / font.

The only solution that i can think of is

  1. Disable cloudflare proxy
  2. Reduce the static files

But both are not good solutions. Any idea?

Thanks

For me this is working perfectly fine on my proxied :orange: domain:

For looking any further into this, please share the domain/URL where the error occurs, while it is proxied, so we can see the issue on our side.

Hi

Yes on the browser it will load propertly. you should use google tools https://search.google.com/test/rich-results

I use pro plan, for the free plan sometimes will face the same problem. but for pro plan it will always get it. Sorry for now i cant reveal the website.

Thanks

Even if analysed with this tool I do not see issue:

Hi M4rt1n

Thank you for your test.

Should look into here

I have checked this aswell… actually made the screenshot before clicking it, but indeed I ensured it works.

It clearly states “All resources were loaded”.

1 Like

Maybe it’s a difference when testing for mobile phone vs desktop? :thinking:

1 Like

To rule that out, here the desktop version:

1 Like

Hi M4rt1n

Thank you for your time. That is odd, i have tried with many pro plan, it happens. but for free plan sometimes i can see all the resources is loaded eventhough the origin server are the same.

Here is the sample link
https://search.google.com/test/rich-results/result?id=vAJ3hxXkirxo4-NzVTyHBw

You are welcome, but I am afreight there is nothing we, in the community can do for you on this one. Google fails to load a ressource and I don’t have your both free and pro links to verify anything. From my end I have tested on:

  • Free
  • Business
  • Enterprise

Packages and all worked flawless, also the free plan. If Google fails to load ressources from your domain while it works on my end, I think you should contact Google so they can look into this and provide you with some more info.

1 Like

HI M4rt1n

Thank you for your reply.

I have tried multiple domain has same result. When i disable the Cloudflare proxy it works perfect.

Wondering anything cause it.

And thats exactly what I can not reproduce. Also you have not provided both demo URLs. One on for pro, one for free plan.

I can just see: test only
And when I tested it, I saw this:


Please disable RocketLoader and try again.

Now we need the second testURL for the package with Pro Plan.

1 Like

HI M4rt1n

Thank you for your reply.

I have disable the rocket loader and other things as per below screenshot

url : https://search.google.com/test/rich-results/result?id=-2Iuw-pp9X-heh8msQHH6A

Kindly, may I suggest you to re-check the HTML code for validation and add the leading and missing <!DOCTYPE html> with the <meta charset="utf-8"> in the <head> as maybe Google does not know what kind of type of a document / URI is he parsing or looking at?

Furthermore, kindly try to add type="text/javascript" attribute onto your script HTML elements as far as maybe Google would know better what kind of external resources it has to load.

  • give it a try to write full URL, like https://yourdomain.com/js/a1.js.

Nevertheless, seems to me like you are missing a semicolon ; in each of your .js files at the end of the line:

var a1= 'a1'; document.getElementById('a').innerHTML += a1 + '<br>'; // semicolon here missing
1 Like

Hi Fritex

Thank you for your reply.

I dont think there is problem on the HTML as on browser is showing ok and when i disable proxy cloudflare it works.

I also have tried full url, and add some html header tag as per your suggestion, it didnt work.
https://search.google.com/test/rich-results/result?id=a72f7fJHaDWxWxykO0G6YQ

I might be out of understanding what the point is and what are you trying to achieve? :thinking:

May I ask what is the general issue here? :thinking:

From my example from below - I have 10/58 resources JS not being loaded (Google AdSense, Google Analytics, other 3rd-party scripts), 13+ warnings for Google Rich snippets (due to being nasted), even 3 console messages due to ServiceWorker Usage, but at the end it’s HTTP 200 “success” and site is indexed, and at the end working pretty well:

Other example, published article - 13/89 resources not being fetched/loaded, 7 console messages:

Third example - mixed one, published article / review article:

AMP URL example - again, warnings, resources couldn’t be fetched/loaded, console messages, but it’s indexed and working:

All examples, using Cloudflare with optimizations, meaning Polish, Mirage, Rocket Loader, etc. and Custom Firewall Rules + Managed WAF Rules.

Bottom line, Cloudflare Rocket Loader resource does not affect this as far as I have multiple other resources from 3rd-party domains being loaded.

Page might be partially loaded due to all resources could not loaded at the given moment for Googlebot while testing by using the above tool.

From my example, the website is fine, working and that’s how it displays in Google Search Console. This the partial load stuff, looking at your site, it mostly is to expect other errors for things like CSS & JavaScript files.
Even Google Analytics or Facebook Pixel throws errors here.

If the content is showing fine and Google can fetch robots.txt file and parese your sitemap.xml file, I believe you are good to go.

The Googlebot is for identifying content on your page. That’s the point here (with rich snippets). It might not be able to track and execute scripts on our websites.

Otherwise, in terms of an SEO optimization, that’s another topic.

1 Like

Hi Fritex

Thank you for your reply and sorry for the confusing.

The website that i want to fix is the full javascript like the prototype, thus if the javascript is not loaded
propertly the content just simply blank on “google eye”. If blank means google cant render my website properly.

Understand for the external javascript is not loaded is ok, because usually the external javascript we dont have control on it e.g google adsense or google analytic.

Im more concern on the internal javascript. as on my prototype all is internal javascript but yet google cant crawl it properly. But when i disable the proxy it works perfect.

You can see on here
https://search.google.com/test/rich-results/result?id=a72f7fJHaDWxWxykO0G6YQ

even you try to retry it, it wont load all internal javascript properly.