Problem with email

#1

Hello people,

I have wordpress website and I used contact form 7 plugin, every time when someone tries to send an email from a website gets a message “There was an error trying to send your message. Please try again later.”.

The problem is probably smtp and MX record, but I don’t know how to set it. I tried everything

Screenshot_7

#2

Here are some good steps to start with.

I assume it’s point 4 in this list:

1 Like
#3

Hi Mark,

I already did that.

#4

Ok, great. Is it the same URL your CMS / website uses to connect to this mail server?
The initial connection to your mail server is slow like hell.

Tested with centralops.net:

SMTP session

[Resolving mail.xxxxx.net...]
[Contacting mail.xxxxx.net [xx.xx.xx.249]...]
[Connected]
[Timed out]
[Timed out]

I needed a few tries from my own server to get a 220 response (‘Service Ready’). And when I received it, it took up to 15 seconds. Do you control this server? I’d check it first. All other commands after the 220 response are handled in time.

From my point of view issues with Cloudflare are ruled out here.

#5

How do you mean same URL for cms and mail server?

I used GoDaddy hosting for this. Before I set up CDN, the emails worked

#6

Looks ok so far. Is there an email sent out as soon as someone subscribes to the newsletter?

I was talking about the host that is configured in your CMS to send emails. Is it mail… or localhost or something else?

Again: I am connecting to your server’s IP directly (which seems to be configured as open relay btw)

[email protected]:~$ telnet xx.xxx.xx.249 25
Trying xx.xxx.xx.249...
Connected toxx.xxx.xx.249.
Escape character is '^]'.

**10 seconds delay to receive this message:**
220-xxxxxxxxxxxxxxxxxxxx.secureserver.net ESMTP Exim 4.91 #1 Wed, 10 Apr 2019 13:54:41 -0700
220-We do not authorize the use of this system to transport unsolicited,
220 and/or bulk e-mail.
HELO wegwerfemail.de
250 xxxxxxxxxxxxxxxxxxxx.secureserver.net Hello wegwerfemail.de [xx.xxx.xxx.xxx]
MAIL FROM: [email protected]
250 OK
RCPT TO: [email protected]
250 Accepted
DATA
354 Enter message, ending with "." on a line by itself
CF Community Troubleshooting
.
250 OK id=1hEKH7-003NxI-Bh

Email sent.

Plus that i got locked out for a few minutes. Either because I did send an email without authentication, or it’s a very low rate limit.

[email protected]:~$ telnet xx.xxx.xx.249 25
Trying xx.xxx.xx.249...
Connected to xx.xxx.xx.249.
Escape character is '^]'.
451-The server has reached its limit for processing requests from your host.
451 Please try again later.
Connection closed by foreign host.
#7

I tried everything
[/quote]
Everything? :slight_smile:
In the Dev Tools console, I’m seeing an error for wpcf7-response-output wpcf7-display-none wpcf7-spam-blocked for the newsletter sign-up. You can also try disabling Rocket Loader.

1 Like
closed #8

This topic was automatically closed after 14 days. New replies are no longer allowed.