Problem with editing the dns servers after connecting the domain to the shopify store

Hello, I have a problem with editing dns servers. I have a domain from OVH (with DNS servers changed to Cloudflare, and that’s how I manage the domain) and after connecting the domain with shopify, when I wanted to move to another machine, when removing and adding the A record again, it keeps redirecting to some error page from shopify. Of course, I waited 48 hours after editing, as I was also told in the shopify support, they said that if the error persists, I should report it to them, after writing to them after 48 hours, I only got a reply that I should write directly to Cloudflare (XD). I really need this domain to work due to the fact that I run a shop and its unavailability brings huge losses to my business :frowning:

Ugh, sorry for the issues. We see similar issues with Cloudflare for saas providers and hostnames, although this sounds slightly different than the other issues we have seen reported here.

Specifically, most other similar cases involve moving from WP Engine to Shopify, or more generally from one Cloudflare for saas provider to another provider, as opposed to moving from one machine to another. Nonethelesss, this solution may help. If you follow this #tutorial to the liberate the hostname section that may address the issue you’re having

I tried to use the page that was given there, but even though I don’t have any CNAME record that is displayed in the user panel, I can’t add a new record (It says that this is the case) ;/ If someone from support could check why this is happening, I would be really grateful

I’m not trying to contact shopify again because they say it’s not their fault and I’m supposed to contact Cloudflare…

1 Like

They love to say that and we end up in a wonderful game of ping pong back and forth.

Liberate the Hostname? If so, can you post a screenshot of the error when you try to follow the instructions there?

1 Like

Can you confirm the domain name? Do you have another record using the same name as the one you are trying to add?

When I try to add a new CNAME record that is showing me on this page I get an error

Everything is shown above

Just as the error says, you are trying to create a CNAME record where you already have an A record by the same name. You can see it in your screenshot right below the record for test. You cannot have other records that share a name with the alias of a CNAME. You will need to delete that A record if you need the CNAME.


Yes, I’m a bit stupid but I was also doing this at 4am my local time and spent the whole night trying to find a solution. It worked and the domain is fixed, thank you all for your help :mending_heart:

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.