Problem with dns to Cloudflare

Hello everyone, I have a very strange problem, I have added Cloudflare without problems to several domains of a Centos server with Plesk, and yet there is one, that does not solve and I have tried everything. The Dns in Plesk are correct, like the other domains.

This is the log when I accest to the page:

2019-11-09 11:44:52 Access 301 GET / HTTP/1.1

Hi @user6593,

Here is the standard info on the error I get when accessing the page, however being on a partner setup, you may get more help by contacting the provider you configured Cloudflare through.

The errors “The page isn’t redirecting properly” or “ERR_TOO_MANY_REDIRECTS” indicates a redirect loop between Cloudflare and your origin server. The easiest fix for this is to remove the redirect on your origin server. For a more detailed set of options, review the troubleshooting suggestions in this Community Tip.

You most likely have “Flexible” set as SSL mode on Cloudflare. Switch that to “Full strict”.

Hi, I think its no problem of Cloudflare, if I upload a file called index.html work fine. But when add the wordpress page made a lo of redirections!, Im crazy, try a lot of options and nothing.

This is the DNS work fine in other clients…

Have you changed the SSL mode?

just now I change from “Full” to “Flexible”, but the same error.

In our Cloudflare panel say “Pending Nameserver Update”, maybe I must whait some time, but in other clients its very fast.

“Full strict”, not “Full”.

It seems to load fine at this point →

How did you add your site? On Cloudflare or via your host?

Did you just change something? It loaded fine and now is back to a redirection loop.

I Sandro, in Plesk I add all the domains with Cloudflare, but into Cloudflare don’t show the domain and I create it manually.

Just now I change SSL from Flexible to Full Strict, the certificate of the web is Comodo.

So right now it is “Full strict”?

yes, and I delete the plugin Rocket loader and depure the .htaccess file, I delete this code also:

RewriteEngine On
RewriteCond %{SERVER_PORT} 80
RewriteRule ^(.*)$ /$1 [R=301,L]

I suspect that there may be an issue with the partner setup in this case, on the DNS tab for the domain in Cloudflare, does it show ‘DNS managed by a partner’ or does it show a list of DNS records?

1 Like

At this point I am afraid I can only refer you to your host’s support. Your setup should be okay at this point and if it isnt there might be something broken. @domjh raised an excellent point, if you set up your domain in different ways you might have ended up with a broken configuration, but unfortunately you didnt answer that particular question earlier.

Your host will be your best point of contact for the time being.

1 Like

Hi Domjh, where can I remove the redirect in our Plesk Panel?, thanks very much in advanced for your help.

I have never used Plesk, I’m afraid and have no idea where you may find the redirect.

What may be causing the issue is the possible misconfiguration we mentioned:

thanks for your help, finally I deactivate Cloudflare, and when I have the control in Wordpress want install the plugin Cloudflare redirect and try again.