Problem with Cloudflare Pages and DNS

Hello, I recently bought a domain from Google, I made the installations. For the first 12 days, the site worked fine (hosted with Cloudflare Pages), I was very satisfied, but on the 3rd day I realized that I could not enter the site from the domain. When I tried it, I noticed that the default link given by Cloudflare Pages works. Then, when I added new subdomains, I noticed that they did not work, so there is a problem with the entire domain or dns in general. Then, when I tried to enter the site with another browser, the site opened, but it did not open in Firefox, then I sent the link to a friend in Discord, I noticed that there was no OG in the link, then when I tried it on my laptop within the same day (I tried with Firefox again), it did not open there either. Very happy if you help.

What’s the domain?

DNS record exists, looks good from Pages side and I can verify the site works.

Can you:

  1. Run a dig on the domain (dig
  2. Screenshot what page you’re seeing

"We cannot find the site you are looking for.

We were unable to connect to the server.

If you entered the correct address, you can:

 try again later
 Check your network connection
 Check if the Firefox browser is allowed to access the web (You may be behind a firewall even if you are connected)"

(I didn’t send ss because my browser’s language is different.)
" ------------ (3/26/2023 7:51:04 PM) ------------


; (1 server found)
;; Got answer:
;; ->>HEADER<<- opcode: Query, status: No Error, id: 15632
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 1

; EDNS: version: 0, flags:; UDP: 4096; code: NoError

;; AUTHORITIES SECTION: 296 IN SOA 2305334552 10000 2400 604800 3600

;; Query time: 0 msec
;; WHEN: Sun Mar 26 16:51:04 Z 2023
;; MSG SIZE rcvd: 115

It looks like when you moved the domain to Cloudflare, DNSSEC was enabled, and you didn’t first disable it. Try either (1) enabling DNSSEC at Cloudflare and adding the DS record at your domain registrar; or (2) disabling DNSSEC at your registrar and removing the records there.

1 Like

Google says DNSSEC records are published, but Cloudflare does not confirm this.

Yes, that’s the problem. If you move DNS to another host the DNSSEC can’t just transfer. You have to either disable it at the registrar and remove the DS records, or enable it at Cloudflare and replace the DS records at the registrar with ones from Cloudflare.

1 Like

Everything seems fine, I guess I’ll have to turn DNSSEC off or switch to Google’s own DNS.

There is a third option:

I already did.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.