Problem with Argo running as a service Windows


#1

Hi, I am trying to get Argo Tunnel up and running on Windows Server 2016. It works completely fine when I enter “cloudflared --hostname [ my hostname] http://localhost:80”. It also works fine when I point it to a config.yml. When I run it as a service and put the config.yml in "C:\Windows\system32\config\systemprofile\cloudflared\config.yml " it does not work even after restarting the system and restarting the service. Any help will be much appreciated

.


#2

The screenshot shows where the service contents are located and the running service. Can’t seem to figure out why it does not work.


#3

Sorry about the confusion, the cloudflared directory should be .cloudflared (notice the dot). We’ll update the docs shortly to the correct path.

Joaquin


#4

Got it thank you.


#5

Another question. I am running a WordPress site behind the tunnel and it appears the login page is inaccessible via the tunnel. Any ideas?


#6

Also the solution worked. Thank you.


#7

What problems are you seeing? I tried installing wordpress on docker and proxying through cloudflared and I was able to setup the site, login and post.


#8

Ok so the issue is definetely a redirect issue. I ran cloudflared via the console and I saw a redirect loop. One solution would be to disable https which can be a hassle. Or somehow connect the tunnel to port 443 on the webserver with a certificate.

Is there any way to connect server to tunnel with a certificate?

Thanks.


#9

Specify port 443 instead of 80.

cloudflared --hostname [ my hostname] http://localhost:443”.


#10

Ok I got that to work by specifying the origin server name to the tunnel so the original certificate would work. Website appears to work fine but login and register pages timeout. This is a wordpress site by the way. Here are my logs when I click login.
POST https://192.168.1.32:443/login/ HTTP/1.1 CF-RAY=40b1048abc352513-ORD
POST https://192.168.1.32:443/login/ HTTP/1.1 CF-RAY=40b1049aa9862513-ORD
Thanks
Also tried deactivating all plugins. No luck


#11

I have a much simpler set up, with just experimenting with a new version of my website. I have a test python server running at http://localhost:8000 and test.ethanhs.me set as my hostname. However, I cannot get to my site to load. I have a config file in C:\Windows\System32\config\systemprofile\.cloudflared, what am I doing wrong?

Nevermind I seem to have fixed the problem.