Problem when SSL from another vendor installed


#1

I operate a server with a dozen domain names. One of the domains (let’s call it “abc.com”) has an SSL cert installed from GoDaddy. I install Cloudflare on any other domain on the server (“xyz.com”), and, rather than securing and showing xyz.com, one is immediately redirected to abc.com.

This, of course, was not happening until Cloudflare was enabled. Any insight?


#2

You currently don’t have any domains on Cloudflare so hard to say, but likely something misconfigured on the origin server.


#3

I removed them all because of the issue. I added one back in as an example.

Try this: It automatically redirects to which is not on Cloudflare, but which has the SSL installed that was purchased from GoDaddy. Thanks for your help.

#4

I removed them all because of the issue.
I’ve added one back in as an example.

Here is a domain configured with Cloudflare SSL.

You’ll notice it automatically redirects to https://frontrange360.com which is not on Cloudflare, but which has a SSL cert installed from GoDaddy and is on the same server as the other.


#5

Your origin is returning a 200 response and the page is being redirected by code on the page loaded.

curl -I https://jeroldirvin.com/   
HTTP/2 200
date: Sat, 11 Aug 2018 17:51:26 GMT
content-type: text/html;charset=UTF-8
set-cookie: __cfduid=d3d1d4138f930fbef8f5f46c5d122544f1534009886; expires=Sun, 11-Aug-19 17:51:26 GMT; path=/; domain=.jeroldirvin.com; HttpOnly; Secure
vary: Accept-Encoding
set-cookie: CFID=13250064; Expires=Sun, 12-Aug-2018 17:51:25 GMT; Path=/; HttpOnly
set-cookie: CFTOKEN=25bb8a2050c9113a-A523C5C6-1016-4515-CDAD7C287BDC5417; Expires=Sun, 12-Aug-2018 17:51:25 GMT; Path=/; HttpOnly
set-cookie: CFGLOBALS=urltoken%3DCFID%23%3D13250064%26CFTOKEN%23%3D25bb8a2050c9113a%2DA523C5C6%2D1016%2D4515%2DCDAD7C287BDC5417%23lastvisit%3D%7Bts%20%272018%2D08%2D11%2010%3A51%3A25%27%7D%23hitcount%3D2%23timecreated%3D%7Bts%20%272018%2D08%2D11%2010%3A51%3A25%27%7D%23cftoken%3D25bb8a2050c9113a%2DA523C5C6%2D1016%2D4515%2DCDAD7C287BDC5417%23cfid%3D13250064%23; Expires=Mon, 03-Aug-2048 17:51:25 GMT; Path=/; HttpOnly
x-content-type-options: nosniff
expect-ct: max-age=604800, report-uri="https://report-uri.cloudflare.com/cdn-cgi/beacon/expect-ct"
server: cloudflare
cf-ray: 448c8cda6f277f06-SFO-DOG

The same thing happens when I hit your origin directly bypassing Cloudflare when visiting the https version of your site. It sounds like you may not have the virtual server configured correctly for other hosts on port 443 so it is defaulting to some default page which includes this code causing the redirection:

meta HTTP-EQUIV=“REFRESH” content=“0; url=http://frontrange360.com/isbetter/”

You can confirm this by looking at the output using

curl -k https://jeroldirvin.com/


#6

Thanks so much for the help! I figured it was on my end, now I just need to figure out the steps to solve it. Do you know of a tutorial on this topic? Thanks!


#7

With your current setup? Probably steps 1-10. I am not sure the cert has to match the host name on the origin, just that the origin needs to know the site is available on https.

https://support.microsoft.com/en-us/help/324069/how-to-set-up-an-https-service-in-iis


#8

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.