Problem using SSL in .ml & .tk domains

Hi,

I added Cloudflare to my website yesterday and everything seemed to fine. However, today I faced an error of reaching my website because of some SSL error.

I am using really simple ssl wordpress plugin, and the Cloudflare status is: Ineligible for SSL (because I think my website is a .ml domain)

Now my question is that if Cloudflare ssl can’t be used for .ml domains, how can I disable it and use my own ssl.

I just need the CDN of Cloudflare. Can anyone suggest me what to do?

I would say you to move on to dot com or any TLD these domains won’t give you anything, and Google also won’t rank these free domains, so it’s better to move.

1 Like

But I can’t seem to afford to move to any premium TLD right now. Also, I heard that .com domains are not doing good in SEO nowadays.

1 Like

I’ve put a .tk domain on Cloudflare with SSL before. Don’t know about .ml, though. I don’t know why either would be “Ineligible for SSL.” You can try contacting support:
https://dash.cloudflare.com/?account=support

As for a better TLD, many good ones cost less than $20/year.

1 Like

I only see one domain associated with your account and it is a .com domain.

I have a .ml domain on a free plan which has a Cloudflare universal SSL cert, so there isn’t a prohibition against SSL for that domain. However, if you’d like yo use your own SSL certificate, you can upload that if you are on the business plan.

1 Like

Yeah, I removed it because it was giving me an error. I will add it once the issue gets resolved.

This error is basically a miscommunication indicator which tells that the web browser you are using and the web server is unable to exchange details.

However, first I would suggest you to read this link for information on setting up WordPress sites using Cloudflare.

Then, try the setup again by adding it your Cloudflare account and change the nameservers in your Hosting Server.

It doesn’t matter what domain or TLD are you on, Cloudflare works efficiently on each one of them. However, if you’re still facing the issue, you can fix Fix Err_SSL_Version_Or_Cipher_Mismatch Error from this link.

1 Like

Hi, thanks for reaching out. I was also planning to do it myself. Going to try it now.

This worked. Thanks a ton!!!

This topic was automatically closed after 30 days. New replies are no longer allowed.