Problem using Cloudflare and 000webhost


#1

Hello everyone, I’m new in this community and I was wondering if you could help me. Yesterday I joined Cloudflare, and since then I’m trying to associate it with my Joomla! website (hosted on 000webhost), but I still couldn’t make it work (I used this tutorial).
Cloudflare says it’s already active, and I just checked on Whois and it seems to be pointed well. I also checked on www.host-tracker.com and it says “301 moved permanently”, no idea what it means.
When I visit my website, I get different results: sometimes, it says “ERR_TOO_MANY_REDIRECTS”. Other times, there’s a white page, it’s all empty. And I just tried again in Chrome (I also tried with IE and Edge) and it showed me this error:

Error 524 A timeout occurred
Browser Working
Cloudflare Working
Host Error

Does anyone know what could be wrong? I would appreciate any suggestion. Thanks in advance!!


#2

By the way, this is my site. Thanks again!


#3

Seems you have a more serious problem.

Page is showing up for me. You’re behind cloudflare and SSL is working fine.
Too many redirects is a common issue with Wordpress. I can imagine that it’s a similar issue with joomla. How ever first you should fix this:


#4

Hi @MarkMeyer, thank you very much for your reply. You can also see the menus and contents in my website!? :open_mouth: I can’t see anything, I keep getting the same errors or the white page.
Yes, that message appears one hour a day. You’ll see, it’s a free hosting (for small bussinesses, learning and tests, mostly) and they do that to decongest the servers.

I don’t know, I’ll keep checking. It’s been almost 48 hours since I made the changes. Thanks again for your feedback!


#5

When I visit https://factorpsi.com/, it redirects me to https://factorpsi.com/, so that’s the redirect loop.

Do you have a .htaccess file that redirects to https?j

What’s your SSL setting in the Cloudflare Crypto page? Is it Flexible? If so, try setting it to Full or Full (Strict).


#6

@MarkMeyer and @sdayman, I finally fixed it! It wasn’t a problem with Cloudflare but my Joomla’s configuration.php file (it worked perfect without the ssl certificate but now I have those options sent my site to the ground).

For anyone having the same problem with Joomla (I’m running Joomla 3.8.7 and PHP 7.1): I just disabled the ssl option in configuration.php (I changed it from 2 to 0) and the sef option too (changed it from 1 to 0). Now my site loads perfectly fine and it shows the protocol https:// in green :slight_smile: And that’s it!
Now I will take advantage of this situation to clean my site and make some changes. Thanks for all the support, guys.


#7

Glad to hear. Thx for letting us know :slight_smile:


#8

This topic was automatically closed after 14 days. New replies are no longer allowed.