Problem transferring site with domain to a different account

What is the name of the domain?

habariportal.com

What is the error message?

Problems detected resolving the domain habariportal.com: The domain resolves to an incorrect IP address (188.114.97.3). To get your website online, correct DNS settings.

What is the issue you’re encountering

I cannot access the domain at the new hosting account, apparently because of DNS issues.

What steps have you taken to resolve the issue?

I had to move a site from one hosting account to another. I changed the IP address of the site under my Cloudflare account DNS Records, replacing the old one with NEW one under the Hosting and DNS of the Plesk panel. I deleted the domain & data under this OLD account in the Plesk panel. At the new hosting account, I created a new domain but noted an error message, translated from German: “Problems detected resolving the domain habariportal.com:
The domain resolves to an incorrect IP address (188.114.97.3). To get your website online, correct DNS settings.”

If I try to access “http://188.114.97.3/”, part of the error message “You’ve requested an IP address that is part of the Cloudflare network. A valid Host header must be supplied to reach the desired website.”

That IP address is certainly not the one of the NEW hosting account I entered under Cloudflare DNS records.
After uploading the site data, even if I deleted all site data on Plesk panel at old account WITH NOTHING THERE NOW, if I try to access the domain, I am taken to the default server login page of the OLD account with this:

“Web Server’s Default Page
This page is generated by Plesk, the leading hosting automation software.
You see this page because there is no Web site at this address.
Log in to Plesk to create websites and set up hosting”

Since the Plesk panel message implicates Cloudflare “Problems detected resolving the domain habariportal.com:
The domain resolves to an incorrect IP address (188.114.97.3). To get your website online, correct DNS settings.” … when I create the domain at new account and I keep being directed to the default server page of OLD account, what exactly am I supposed to do at the Cloudflare account? What did I do wrong with replacing the IP address of old site with NEW?
I

What feature, service or problem is this related to?

DNS records

What are the steps to reproduce the issue?

I have tried to deleted the domain at new account and to re-create it BUT immediately get the error message:
Problems detected resolving the domain habariportal.com:
The domain resolves to an incorrect IP address (188.114.97.3). To get your website online, correct DNS settings.
What exactly are these correct DNS settings?
Currently under DNS management for my site I had for that domain:
Type A, Name: My Domain, Content: New IP address (replaced old servers), Proxy status: proxied, TTL: auto.
Same values for “www”.
WAS IT WRONG to merely replace the IP address and if not what exactly is the correct step after changing to a different account & hosting server?
I also had some subdomains, that had similar values, whose IP Iupdated to the new one, though those are currently not in use.
I AM NOT an expert on this so I would highly appreciate some simple explanation for this so I get my site ack online.

Thank you very much in advance

Can you share some of the actual data?

What company are you now hosting your site with, which company did you use before, what IP are you supposed to use for the new company?

Also please share a screenshot of your DNS records in Cloudflare.

1 Like

Thank you for the quick response.
There have been so many changes to Cloudflare forum posting process
since I lasted posted years ago. The Reply button to your message is for
some reason on clicking no text box opens, unless I am just not seeing
it, so replying via email. I hope the attached screenshot shows up.

The Web host is Webhost Germany and I am basically moving this domain
from an account where it was an add-on to a different account & server,
also as an add-on domain.
The domain registrar is separate and is Namecheap.

All those entries under DNS settingsin screenshot were made years back.
I just thought it sufficed to just replace the OLD IP address
212.72.184.247 with the NEW one (212.72.184.51) and wouldn’t know what
else to change and would appreciate that being shown to me.

Not quite sure where Plesk panel gets this when I try to create the
domain as eyplained before:

“Problems detected resolving the domain habariportal.com: The domain
resolves to an incorrect IP address (188.114.97.3). To get your website
online, correct DNS settings.”

Thank you in advance.

It looks like you are using the Flexible SSL mode in Cloudflare. You should change that to Full (strict).

That is one of Cloudflare’s IP addresses. Proxied domains resolve to Cloudflare IPs and not the IP you entered.
You might need to change your DNS entry to DNS-Only until your hosting service has verified the domain.

1 Like

I have changed from “Full” where it seems to have been all these years to Full (strict) as you recommend.

Iam grateful for your help, but request for your patience for more clarification as I am quite cornered with nowhere else to run to.

You might need to change your DNS entry to DNS-Only until your hosting service has verified the domain.

What does that mean in practice, what on that panel do I change? Does it mean deleting those “proxied” entries? I just note the new IP would be nowhere on that page.

What do you mean by until the hosting service verifying the domain, if I may ask? Is that not done automatically when I create a domain in the Plesk panel?
What is “DNS-Only”? Would the current entries (like: MX - habariportal.com -
eforward5.registrar-servers.com - DNS only) and the rest made years back work for the new site location + new IP address, for which I actually see nowhere?

Kind regards

On the screenshot you shared, there is a column “proxy status”.

On the entries with the orange clouds, you need to change the proxy status to DNS-Only.

The company seems to check that you have used the correct IP address. They can’t do that while the entry is proxied.

1 Like

OK, so I did both, changing SSL from Full to Full (strict) and changed
the proxy status to DNS-Only.
As of now, within Plesk panel, when I go to that site’s admin & click on
“view in browser” to the link “https://habariportal.com/” where there is
some warning about an SSL certificate. Is the “SSL/TLS” Full (strict)
setting not active here? The page has a warning “Warning: Potential
Security Risk Ahead” in Firefox.

I tried to install a basic SSL certificate provided by the host, but it
failed, saying something about failure of authorization, etc & about
"https://habariportal.com.212-72-184-51.forward.server4all.de/ "

If one goes to"Preview" site also in Plesk, whether to re-install
Wordpress or upload & use the existing site DB & files, one would expect
to see the site or be taken to the Wordpress installation interface.
Instead one gets
https://habariportal.com.212-72-184-51.forward.server4all.de/ , a
default page from the Webhost saying something is gonna be installed
there. At least this shows the new IP address in that url.

If one goes to https://www.habariportal.com/, it leads to the OLD
default server log in page, where the old IP was valid!

So I am still stuck, not quite sure what to do next, … wait?

I had not expected this transfer business to turn into a nightmare. :frowning:

Kind regards

As your site is now in DNS only mode, you will need to work with your host until everything is functioning. No Cloudflare settings apply until then.

You can enable the proxy again after everything is working.

2 Likes

Hi there

In the meantime, after following your advice to contact the host, they helped solve the issue with the site and a subdomain-based connected site as well. This was the response:

The SSL certificate was not set up correctly and therefore not issued. I have corrected this for you, the domain is now accessible.

The basic SSL available through the Plesk administration has been activated.

So if I may ask, is it safe to undo the DNS Only back to Proxied?
Regarding SSL settings now at " Your SSL/TLS encryption mode is Full (strict)", should I leave it at that or go back to former setting “Full”?

What about the Plesk-based SSL-settings using “Let’s Encrypt”, which are active?

I just want to be sure, so the site accessability is not interrupted.

Thank you in advance.

2 Likes

The certificate on your server will last for 3 months.

You need to do some configuration on Cloudflare, or the renewal in 3 months will fail again if you activate the proxy.

here is a guide by @epic.network that explains what you need to do: Mi website is un accesible after update of ssl certificates - #32 by linkp - Help - Let's Encrypt Community Support

1 Like

Hi Laudian
If I may ask, if I under Let’s Encrypt settings on the Plesk panel I deactivated “Redirect HTTP to HTTPS (translated from German)” and everything else like “HSTS”, can I then immediately on the Cloudflare dashboard change from DNS Only => Proxied, like before and leave SSL/TLS encryption mode at Full (strict), would that work and not interrupt site access? If possible, I would like to end this issue ASAP and if possible, exactly which other settings on the Cloudflare & Plesk HTTPs settings would I need to do?

Thank you in advance