Problem running DoH via Cloudflared from Linux [SOLVED]

Hi.

I use a Raspberry Pi as my local DNS server, to filter out adverts and whatnot.

Months ago I set it up to use Cloudflared to resolve over DoH, and it has worked like a charm until recently.

(For the record, I set it up using the pi-hole guidance on the official pi-hole site - link available if you need it.

There haven’t been any deliberate changes to the machine’s connectivity setup over the last few weeks, but I’ve noticed that if I go to https://1.1.1.1/help, “Using DNS over HTTPS (DoH)” states No, where it previously said yes.

Having said that, there are always routine patches (apt update/upgrade) and every month or so I update the cloudflared executable to the latest version. I didn’t notice anything which was obviously going to break this, but I’m not expert. Perhaps less helpfully, I’ve also no idea exactly when this problem started, so going back and undoing any changes isn’t terribly practical.

Find below the diag info that’s normally requested :

https://pastebin.com/dzg0bdzX

(I had to put it on pastebin, because the forum rejected it because it thought there were too many links in it.)

Any advice or guidance would be gratefully accepted.

So it turns out that somehow I’d clicked “use DNSSEC” in the pihole configuration, which, despite still being able to resolve via Cloudflared, somehow stuffed up the DoH. I can’t really understand how it still worked, but it’s clearly something that pihole does internally with that setting.

Solution : Uncheck it. Be more careful next time.

1 Like