Problem in wordpress

i have problem in my wordpress some images are now hiddien and i can see that images when i click on it, and also have problem to add new page or upload images , there is no error message .and datacenter sy that issue from Cloudflare, how to resolve this issue please ,
Thank you.


Thank you for asking.

May I ask have you tried using a different Web browser, or tried clearing your Web browser cache?
How about using a Private window (Incognito mode) or a VPN connection if possible?
Is it the same behaviour on your mobile phone (4G LTE, mobile data, cellular)?

Before moving to Cloudflare, was your Website working over HTTPS connection?

Was WordPress configured to work over HTTPS?

You could determine this by:

  1. Use the “Pause Cloudflare on Site” option from the Overview tab for your domain at .
  2. The link is in the lower right corner of that page.
  3. Give it five minutes to take effect, then make sure site is working as expected with HTTPS without any error
  4. Check with your hosting provider / cPanel AutoSSL / Let’s Encrypt / Certbot / ACME and renew it in case if needed
  5. Only then, when your website responds over HTTPS, you should un-pause Cloudflare and double-check your SSL/TLS setting to make sure it’s Full (Strict).

Otherwise, I’d suggest as follows:

May I ask what SSL option have you got selected under the SSL/TLS tab at Cloudflare dashboard for your domain ( Flexible, Full, Full Strict … )?

Here is a way to re-check if you correctly setup the SSL for your domain with Cloudflare:

In case you do not have an SSL certificate, you can use Cloudflare SSL, if so, kindly make sure you follow the instructions as follows on the below article to setup an SSL certificate using Cloudflare Origin CA Certificate:

Last but not least, kindly have a look here for more information regarding SSL settings at the SSL/TLS tab on Cloudflare dashboard:

Could be if you’re using some kind of a plugin for gallery or lightbox effect, that the “Rocket Loader” feature is in conflict with the JavaScript and being enabled at Cloudflare dashboard → Speed → Optimization :thinking:

May I ask, have you tried disabling the Rocket Loader feature at the Cloudflare dashboard? :thinking:

It might be some conflict with the scripts while loading them.

May I also ask if you’ve got Auto Minify options enabled for HTML, CSS & JS at Cloudflare dashboard? Try disabling them too.

Kindly, may I ask you to check out what option have you got selected by navigating to the Cloudflare dashboard → Caching → Configuration → find section “Browser Cache TTL” and make sure the selected option from the dropdown menu is “Respect Existing Headers”.

Furthermore, from the same menu, click on the blue button saying “Purge Everything” to flush the cache at Cloudflare Edge, just in case.

Wait for a minute or two.

Refresh a page in your Web browser, otherwise try clearing your Web browser cache or use a different Web browser to test out again.

Also, if you checked your Developer Console (F12), are there any error and/or warnings?

Otherwise, maybe the “Auto Minify” for HTML, CSS and/or JavaScript is checked at Cloudflare dashboard → Speed → Optimization, and makes some issues :thinking:

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.